<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 9]>
<html id="ie9" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="p:domain_verify" content="8a90d12ecbe7457c3470670736676383" /> 


<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="http://wwwcdn.goldminemag.com/wp-content/themes/goldmine-mag-theme/style.css?ver=1.5.1" />
<link rel="pingback" href="http://www.goldminemag.com/xmlrpc.php" />
<link rel="shortcut icon" href="/favicon.ico" />

<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js"></script>
<script type="text/javascript">
<!--
$(document).ready(function() {
 
	$('.tabs a').click(function(){
		switch_tabs($(this));
	});
 
	switch_tabs($('.defaulttab'));
 
});
 
function switch_tabs(obj)
{
	$('.tab-content').hide();
	$('.tabs a').removeClass("selected");
	var id = obj.attr("rel");
 
	$('#'+id).show();
	obj.addClass("selected");
}
//-->
</script>
<!--[if lt IE 9]>
<script src="http://wwwcdn.goldminemag.com/wp-content/themes/goldmine-mag-theme/js/html5.js" type="text/javascript"></script>
<![endif]-->

<script type="text/javascript">
var dataLayer = [];
</script>
<script type="text/javascript" src="//assets.adobedtm.com/eeabfecf1ea8efeee8089b11ad6abf60b1923718/satelliteLib-75ece947334e84857cbf24e6f743caf4de53db34.js"></script>
<meta name="adobe-dtm-wordpress" content="true">
<!-- This site is optimized with the Yoast SEO plugin v6.1.1 - https://yoa.st/1yg?utm_content=6.1.1 -->
<title>New Music Reviews for May 2018 - Goldmine Magazine</title>
<link rel="canonical" href="http://www.goldminemag.com/blogs/new-music-reviews-may-2018" />
<link rel="publisher" href="https://plus.google.com/105853805944722221195/posts"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="New Music Reviews for May 2018 - Goldmine Magazine" />
<meta property="og:description" content="Being a music journalist who dabbles in drumming can present something of a dilemma: it’s often tough for me to recommend releases I’m involved in without the dreaded “conflict of interest” charge rearing its not-so-pretty head. But this time out &hellip; &#9658;" />
<meta property="og:url" content="http://www.goldminemag.com/blogs/new-music-reviews-may-2018" />
<meta property="og:site_name" content="Goldmine Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/goldminemag" />
<meta property="article:tag" content="Arthur Alexander" />
<meta property="article:tag" content="Dana Countryman" />
<meta property="article:tag" content="Einstein&#039;s Sister" />
<meta property="article:tag" content="John M. Borack" />
<meta property="article:tag" content="Juliana Hatfield" />
<meta property="article:tag" content="Kai Danzberg" />
<meta property="article:tag" content="Lannie Flowers" />
<meta property="article:tag" content="Matthew Sweet" />
<meta property="article:tag" content="Michael Simmons" />
<meta property="article:tag" content="Mike Collins" />
<meta property="article:tag" content="power pop" />
<meta property="article:tag" content="Power Pop Plus" />
<meta property="article:tag" content="Rooftop Screamers" />
<meta property="article:tag" content="Sean Kelly" />
<meta property="article:tag" content="Sex Clark Five" />
<meta property="article:tag" content="Spygenius" />
<meta property="article:tag" content="The Bottle Kids" />
<meta property="article:tag" content="The Carousels" />
<meta property="article:tag" content="The Choir" />
<meta property="article:tag" content="The Gold Needles" />
<meta property="article:tag" content="The Jeremy Band" />
<meta property="article:tag" content="The Wrecking Two" />
<meta property="article:section" content="Blogs" />
<meta property="article:published_time" content="2018-05-06T03:39:06-05:00" />
<meta property="article:modified_time" content="2018-05-06T16:29:02-05:00" />
<meta property="og:updated_time" content="2018-05-06T16:29:02-05:00" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/Goldmine_Borack_banner-4.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/sweet-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/simmons-300x298.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/31906802_838243953034115_6674295962992640000_n-194x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/81UYGUyT0KL._SX522_-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/tomtxcoqnprva_600-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/268x0w.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/BOTTLE-KIDS-2018-Let-me-in-on-this-action-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/2B2F8D71A-9119-582F-E1EE6C4D6F7B3C17.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/51ejHuK7rVL._SY355_-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/sexclarkfive-300x272.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/jeremyjoycomes.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/Sean_Kelly_-_Time_Bomb_1024x1024-300x300.jpg" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10-291x300.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Being a music journalist who dabbles in drumming can present something of a dilemma: it’s often tough for me to recommend releases I’m involved in without the dreaded “conflict of interest” charge rearing its not-so-pretty head. But this time out &hellip; &#9658;" />
<meta name="twitter:title" content="New Music Reviews for May 2018 - Goldmine Magazine" />
<meta name="twitter:site" content="@goldmine_mag" />
<meta name="twitter:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/Goldmine_Borack_banner-4.jpg" />
<meta name="twitter:creator" content="@goldmine_mag" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.goldminemag.com\/","name":"Goldmine Magazine","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.goldminemag.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/www.goldminemag.com\/blogs\/new-music-reviews-may-2018","sameAs":["https:\/\/www.facebook.com\/goldminemag","https:\/\/plus.google.com\/105853805944722221195\/posts","https:\/\/twitter.com\/goldmine_mag"],"@id":"#organization","name":"Goldmine Magazine","logo":""}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.goldminemag.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Goldmine Magazine &raquo; Feed" href="http://www.goldminemag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Goldmine Magazine &raquo; Comments Feed" href="http://www.goldminemag.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Goldmine Magazine &raquo; New Music Reviews for May 2018 Comments Feed" href="http://www.goldminemag.com/blogs/new-music-reviews-may-2018/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/wwwcdn.goldminemag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://wwwcdn.goldminemag.com/wp-includes/css/dashicons.min.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='theme-my-login-css'  href='http://wwwcdn.goldminemag.com/wp-content/plugins/theme-my-login/theme-my-login.css?ver=6.4.10' type='text/css' media='all' />
<link rel='stylesheet' id='st-widget-css'  href='http://wwwcdn.goldminemag.com/wp-content/plugins/share-this/css/style.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://wwwcdn.goldminemag.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.8' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('http://wwwcdn.goldminemag.com/wp-content/plugins/wp-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wp-form-css'  href='http://wwwcdn.goldminemag.com/wp-content/plugins/fw-exacttarget-forms/css/frontend.form.css?ver=0.1.0' type='text/css' media='screen' />
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.7.2'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/theme-my-login/modules/themed-profiles/themed-profiles.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/fw-exacttarget-forms/js/et_onsubmit.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?onload=etCaptchaInit&#038;render=explicit&#038;ver=4.8.2'></script>
<link rel='https://api.w.org/' href='http://www.goldminemag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.goldminemag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://wwwcdn.goldminemag.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='http://www.goldminemag.com/?p=312264' />
<link rel="alternate" type="application/json+oembed" href="http://www.goldminemag.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.goldminemag.com%2Fblogs%2Fnew-music-reviews-may-2018" />
<link rel="alternate" type="text/xml+oembed" href="http://www.goldminemag.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.goldminemag.com%2Fblogs%2Fnew-music-reviews-may-2018&#038;format=xml" />
<!-- OpenX header script -->
                   <script type="text/javascript" src="http://fwmedia-d.openx.net/w/1.0/jstag"></script>
                   <script type="text/javascript">
                     var OX_526fcbdfe7090 = OX();
                     OX_526fcbdfe7090.addVariable("kw", "cat33921,cat33971,post312264,tag63701,tag111893,tag114454,tag55921,tag88294,tag114448,tag97521,tag55911,tag99671,tag99691,tag24511,tag112414,tag114449,tag114451,tag111557,tag114458,tag114455,tag114456,tag114453,tag114452,tag114450,tag114457")
                     OX_526fcbdfe7090.addPage("16756");
                     OX_526fcbdfe7090.fetchAds();
                   </script>
                   <!-- end generated tag --><!-- Category Reference
Category 33921 = Blogs
Category 33971 = Power Pop Plus
Tag 63701 = Arthur Alexander
Tag 111893 = Dana Countryman
Tag 114454 = Einstein's Sister
Tag 55921 = John M. Borack
Tag 88294 = Juliana Hatfield
Tag 114448 = Kai Danzberg
Tag 97521 = Lannie Flowers
Tag 55911 = Matthew Sweet
Tag 99671 = Michael Simmons
Tag 99691 = Mike Collins
Tag 24511 = power pop
Tag 112414 = Power Pop Plus
Tag 114449 = Rooftop Screamers
Tag 114451 = Sean Kelly
Tag 111557 = Sex Clark Five
Tag 114458 = Spygenius
Tag 114455 = The Bottle Kids
Tag 114456 = The Carousels
Tag 114453 = The Choir
Tag 114452 = The Gold Needles
Tag 114450 = The Jeremy Band
Tag 114457 = The Wrecking Two
-->
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<script charset="utf-8" type="text/javascript">var switchTo5x=true;</script><script charset="utf-8" type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script><script type="text/javascript">stLight.options({publisher:'wp.784b3f5d-3209-45fd-90e8-0c08e8a66cba', onhover: false});var st_type='wordpress3.2.1';</script><script type='text/javascript'>/* <![CDATA[ */ var _wpaudio = {url: 'http://wwwcdn.goldminemag.com/wp-content/plugins/wpaudio-mp3-player', enc: {}, convert_mp3_links: false, style: {text_font:'Sans-serif',text_size:'18px',text_weight:'normal',text_letter_spacing:'normal',text_color:'inherit',link_color:'#24f',link_hover_color:'#02f',bar_base_bg:'#eee',bar_load_bg:'#ccc',bar_position_bg:'#46f',sub_color:'#aaa'}}; /* ]]> */</script>
<!-- Google Tag Manager for WordPress by DuracellTomi - http://duracelltomi.com -->
<script data-cfasync="false" type="text/javascript">
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
	dataLayer.push({"pagePostType":"post","pagePostType2":"single-post","pageCategory":["blogs","power-pop-plus"],"pageAttributes":["arthur-alexander","dana-countryman","einsteins-sister","john-m-borack","juliana-hatfield","kai-danzberg","lannie-flowers","matthew-sweet","michael-simmons","mike-collins","power-pop","power-pop-plus","rooftop-screamers","sean-kelly","sex-clark-five","spygenius","the-bottle-kids","the-carousels","the-choir","the-gold-needles","the-jeremy-band","the-wrecking-two"],"pagePostAuthor":"John Borack"});
</script>
<script data-cfasync="false">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5LJFPS');</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by DuracellTomi --><script type="text/javascript" src="http://wwwcdn.goldminemag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1525651296"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->
</head>

<body class="post-template-default single single-post postid-312264 single-format-standard singular two-column right-sidebar">
<div id="page" class="hfeed">
	<header id="branding" role="banner">
			<hgroup>
							<span id="site-title">Goldmine Magazine</span>
						</hgroup>

                        <div style="height:94px;"> <!--DEVOPS-5109 add space to prevent shifting from ads -->
			<script type="text/javascript">OX_526fcbdfe7090.showAdUnit('468627');</script>  <!--DEVOPS-5109 uncommented-->
                        </div>
			 <a href="/" alt="Goldmine Magazine" /><img class="logo" src="http://wwwcdn.goldminemag.com/wp-content/uploads/GM_Logo_Y_w_sub_800px.png" /></a> 

			<nav id="access" role="navigation">
				<h3 class="assistive-text">Main menu</h3>
								<div class="skip-link"><a class="assistive-text" href="#content" title="Skip to primary content">Skip to primary content</a></div>
				<div class="skip-link"><a class="assistive-text" href="#secondary" title="Skip to secondary content">Skip to secondary content</a></div>
								<div class="menu-top-navigation-container"><ul id="menu-top-navigation" class="menu"><li id="menu-item-266851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-266851"><a href="http://www.goldminemag.com/articles/">Articles</a>
<ul  class="sub-menu">
	<li id="menu-item-266861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-266861"><a href="http://www.goldminemag.com/news/">News</a>
	<ul  class="sub-menu">
		<li id="menu-item-267031" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267031"><a href="http://www.goldminemag.com/news/obituaries-news/">Obituaries</a></li>
		<li id="menu-item-266881" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266881"><a href="http://www.goldminemag.com/news/disc-news/">Disc News</a></li>
		<li id="menu-item-267021" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267021"><a href="http://www.goldminemag.com/news/music-news/">Music News</a></li>
		<li id="menu-item-266871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266871"><a href="http://www.goldminemag.com/news/artist-news/">Artist News</a></li>
		<li id="menu-item-267041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267041"><a href="http://www.goldminemag.com/news/tour-news-news/">Tour News</a></li>
	</ul>
</li>
	<li id="menu-item-309164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-309164"><a href="http://www.goldminemag.com/articles/10-albums-that-changed-my-life/">10 Albums</a></li>
	<li id="menu-item-267331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267331"><a href="http://www.goldminemag.com/collector-resources/for-the-record/">For The Record</a></li>
	<li id="menu-item-266951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266951"><a href="http://www.goldminemag.com/articles/high-fidelity/">High Fidelity</a></li>
	<li id="menu-item-266931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266931"><a href="http://www.goldminemag.com/articles/discoveries/">Discoveries</a></li>
	<li id="menu-item-266971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266971"><a href="http://www.goldminemag.com/articles/flashback/">Flashback</a></li>
	<li id="menu-item-267341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267341"><a href="http://www.goldminemag.com/articles/rock-and-roll-hall-of-fame/">Rock And Roll Hall Of Fame</a></li>
	<li id="menu-item-266991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266991"><a href="http://www.goldminemag.com/articles/where-are-they-now-article/">Where Are They Now?</a></li>
	<li id="menu-item-266981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266981"><a href="http://www.goldminemag.com/articles/sounding-off/">Sounding Off</a></li>
	<li id="menu-item-266961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266961"><a href="http://www.goldminemag.com/articles/readers-choice/">Readers&#8217; Choice</a></li>
	<li id="menu-item-266921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266921"><a href="http://www.goldminemag.com/articles/backstage-pass-article/">Backstage Pass</a></li>
</ul>
</li>
<li id="menu-item-267051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-267051"><a href="http://www.goldminemag.com/reviews/">Reviews</a>
<ul  class="sub-menu">
	<li id="menu-item-267061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267061"><a href="http://www.goldminemag.com/reviews/album-reviews/">Album Reviews</a></li>
	<li id="menu-item-267081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267081"><a href="http://www.goldminemag.com/reviews/blu-ray-reviews/">Blu-ray Reviews</a></li>
	<li id="menu-item-267101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267101"><a href="http://www.goldminemag.com/reviews/best-live-albums/">Best Live Albums</a></li>
	<li id="menu-item-267091" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267091"><a href="http://www.goldminemag.com/reviews/concert-reviews/">Concert Reviews</a></li>
	<li id="menu-item-267071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267071"><a href="http://www.goldminemag.com/reviews/dvd-reviews/">DVD Reviews</a></li>
	<li id="menu-item-267111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267111"><a href="http://www.goldminemag.com/reviews/book-reviews/">Book Reviews</a></li>
</ul>
</li>
<li id="menu-item-267171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-267171"><a href="http://www.goldminemag.com/goldmine_hof/">Goldmine Hall of Fame</a>
<ul  class="sub-menu">
	<li id="menu-item-267181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267181"><a href="http://www.goldminemag.com/goldmine_hof/goldmine_hof_articles/">Goldmine Hall of Fame Articles</a></li>
	<li id="menu-item-267191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267191"><a href="http://www.goldminemag.com/goldmine_hof/goldmine_hof_criteria/">Goldmine Hall of Fame Criteria</a></li>
	<li id="menu-item-267201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267201"><a href="http://www.goldminemag.com/goldmine_hof/goldmine_hof_inductees/">Goldmine Hall of Fame Inductees</a></li>
</ul>
</li>
<li id="menu-item-266891" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-266891"><a href="http://www.goldminemag.com/blogs/">Blogs</a>
<ul  class="sub-menu">
	<li id="menu-item-267131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267131"><a href="http://www.goldminemag.com/blogs/american-back-roads-blogs/">American Back Roads</a></li>
	<li id="menu-item-267141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267141"><a href="http://www.goldminemag.com/blogs/california-60s/">California 60s</a></li>
	<li id="menu-item-293412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293412"><a href="http://www.goldminemag.com/blogs/filled-with-sound/">Filled With Sound</a></li>
	<li id="menu-item-267121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267121"><a href="http://www.goldminemag.com/blogs/great-blogs-of-fire/">Great Blogs Of Fire</a></li>
	<li id="menu-item-306705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-306705"><a href="http://www.goldminemag.com/blogs/indie-showcase/">Indie Showcase</a></li>
	<li id="menu-item-267151" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-267151"><a href="http://www.goldminemag.com/blogs/power-pop-plus/">Power Pop Plus</a></li>
	<li id="menu-item-294305" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-294305"><a title="Spin Cycle Blog" href="http://www.goldminemag.com/blogs/">Spin Cycle Blog</a></li>
	<li id="menu-item-266901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266901"><a href="http://www.goldminemag.com/blogs/sounds-from-across-the-pond/">Sounds From Across The Pond</a></li>
	<li id="menu-item-308575" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-308575"><a href="http://www.goldminemag.com/blogs/vinyl-finds/">Vinyl Finds</a></li>
</ul>
</li>
<li id="menu-item-267211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-267211"><a href="http://www.goldminemag.com/collector-resources/">Music Collector Resources</a>
<ul  class="sub-menu">
	<li id="menu-item-271071" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271071"><a href="http://www.goldminemag.com/record-store-directory/">Record Stores</a></li>
	<li id="menu-item-267451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267451"><a href="http://www.goldminemag.com/collector-resources/record-grading/">Record Grading</a></li>
	<li id="menu-item-267471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267471"><a href="http://www.goldminemag.com/collector-resources/record-store-day/">Record Store Day</a></li>
	<li id="menu-item-267461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267461"><a href="http://www.goldminemag.com/collector-resources/record-show-calendar/">Record Show Calendar</a></li>
	<li id="menu-item-308573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-308573"><a href="http://www.goldminemag.com/collector-resources/record-store-recon/">Record Store Recon</a></li>
	<li id="menu-item-267231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-267231"><a href="http://www.goldminemag.com/collector-resources/collectors-corner-collector-resources/">Collector&#8217;s Corner</a>
	<ul  class="sub-menu">
		<li id="menu-item-267221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267221"><a href="http://www.goldminemag.com/collector-resources/collector-supplies/">Collector Supplies</a></li>
		<li id="menu-item-267241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267241"><a href="http://www.goldminemag.com/collector-resources/collectors-voice/">Collector&#8217;s Voice</a></li>
		<li id="menu-item-267261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267261"><a href="http://www.goldminemag.com/collector-resources/want-lists/">Want Lists</a></li>
		<li id="menu-item-267271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267271"><a href="http://www.goldminemag.com/collector-resources/sound-advice-collector-resources/">Sound Advice</a></li>
		<li id="menu-item-267281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267281"><a href="http://www.goldminemag.com/collector-resources/our-readers/">Our Readers</a></li>
		<li id="menu-item-267321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267321"><a href="http://www.goldminemag.com/collector-resources/for-the-record/">For The Record</a></li>
		<li id="menu-item-267291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267291"><a href="http://www.goldminemag.com/collector-resources/beyond-vinyl/">Beyond Vinyl</a></li>
		<li id="menu-item-267301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267301"><a href="http://www.goldminemag.com/collector-resources/market-watch/">Market Watch</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-267481" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267481"><a href="http://www.goldminemag.com/giveaway/">Giveaway</a></li>
<li id="menu-item-310035" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-310035"><a title="The Goldmine Magazine Podcast" href="http://www.goldminemag.com/goldmine-magazine-podcast/">Podcast</a></li>
<li id="menu-item-267491" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-267491"><a target="_blank" href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_SPECIAL?ikey=K**D12">Subscribe</a>
<ul  class="sub-menu">
	<li id="menu-item-292315" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-292315"><a title="Choose between paper and PDF" target="_blank" href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_SPECIAL?ikey=K**D12">Goldmine Magazine Print OR Digital Subscription</a></li>
	<li id="menu-item-295890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-295890"><a title="Goldmine Subscription: Easy, affordable, appreciated" target="_blank" href="https://ssl.palmcoastd.com/07639/apps/GFTOPTION1LANDING?ikey=I**BG1">Give a Gift</a></li>
	<li id="menu-item-267501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267501"><a title="Watch out for fraudulent mailings" href="http://www.goldminemag.com/subscribe-2/alert/">Subscription Fraud Alert!</a></li>
	<li id="menu-item-267541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267541"><a title="FREE news and updates" href="http://www.goldminemag.com/subscribe-2/enewsletter/">Get Our eNewsletter</a></li>
</ul>
</li>
<li id="menu-item-306548" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-306548"><a href="http://www.goldminemag.com/about-us/">About</a>
<ul  class="sub-menu">
	<li id="menu-item-306549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306549"><a href="http://www.goldminemag.com/about-us/">About Goldmine Magazine and How to Contact Us</a></li>
	<li id="menu-item-306547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306547"><a href="http://www.goldminemag.com/advertise/">Advertise</a></li>
</ul>
</li>
<li id="menu-item-266811" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-266811"><a target="_blank" href="http://www.krausebooks.com/category/records?lid=gmnnav3&#038;r=gmnnav3#new_tab">Shop</a>
<ul  class="sub-menu">
	<li id="menu-item-266841" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-266841"><a target="_blank" href="http://www.krausebooks.com/category/records-price-guides?lid=gmpphm022311priceguides&#038;r=gmpphm022311priceguides#new_tab">Price Guides</a></li>
	<li id="menu-item-267551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267551"><a href="http://www.krausebooks.com/records-cd-dvd">CD/DVDs &#038; Download Resources</a></li>
	<li id="menu-item-266821" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-266821"><a target="_blank" href="http://www.krausebooks.com/category/records?lid=gmpphm022311recordsvinyl&#038;r=gmpphm022311recordsvinyl#new_tab">Records &#038; Vinyl</a></li>
	<li id="menu-item-266831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-266831"><a href="http://www.goldminemag.com/shop/webinars/">Webinars</a></li>
	<li id="menu-item-267561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267561"><a href="http://www.krausebooks.com/rock-n-roll-artists">Rock &#8216;n&#8217; Roll Books</a></li>
</ul>
</li>
</ul></div>			</nav><!-- #access -->
	</header><!-- #branding -->

	<div id="main">
		<div id="secondary" class="widget-area" role="complementary">

			<div id="admin">



				<form method="get" id="searchform" action="http://www.goldminemag.com/">
		<label for="s" class="assistive-text">Search</label>
		<input type="text" class="field" name="s" id="s" value="Search GoldmineMag" onfocus="if (this.value == 'Search GoldmineMag') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search GoldmineMag';}" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
	</form>
 

			<div id="userLinks">
			                            		
			<a href="http://www.goldminemag.com/login?action=register">Register</a> 
			<a href="http://www.goldminemag.com/login">Log In</a>
						</div>

			<div id="socialLinks">

                        <a href="https://www.facebook.com/goldminemag/" alt="Goldmine Magazine on Facebook" target="_blank" style="background-position:-32px 0;" >&nbsp;</a> 
			<a href="http://twitter.com/Goldmine_mag" alt="Goldmine Magazine on Twitter" target="_blank" style="background-position:-2px 0;" >&nbsp;</a> 		
	<!--		<a href="http://www.myspace.com/goldmine.magazine" alt="Goldmine Magazine Myspace" style="background-position:-63px 0;" target="_blank">&nbsp;</a> -->
			<a href="https://www.instagram.com/goldminemagazine" alt="Goldmine Magazine on  Instagram" target="_blank" style="background-position:-189px 0;" >&nbsp;</a> <!--DEVOPS-5109-->
                        <a href="http://www.youtube.com/user/GoldmineMagVideo" alt="Goldmine Magazine on YouTube" style="background-position:-95px 0;" target="_blank">&nbsp;</a> 
			<a href="http://feeds.feedburner.com/GoldmineMagazine" alt="Goldmine Magazine RSS" style="background-position:-127px 0;"  target="_blank">&nbsp;</a>
            			<a href="http://pinterest.com/goldminemag" alt="Goldmine Magazine Pinterest" style="background-position:-158px 0;"  target="_blank">&nbsp;</a>
			</div>
			</div>

			<div id="tabSection" style="margin:115px 0 20px 0;">
			<ul class="tabs">
        		<li><a class="defaulttab" rel="tabs1">News</a></li>
        		<li><a rel="tabs2">Recent Comments</a></li>
    			</ul>

			<div class="tab-content" id="tabs1">

				    						    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/brooklyn-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/brooklyn-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/brooklyn-150x153.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/brooklyn-295x300.jpg 295w, http://wwwcdn.goldminemag.com/wp-content/uploads/brooklyn-147x150.jpg 147w, http://wwwcdn.goldminemag.com/wp-content/uploads/brooklyn-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/brooklyn.jpg 500w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/collector-resources/goldmine-record-show-calendar-may-2018" title="Permalink to Goldmine Record Show Calendar, May 2018" rel="bookmark">Goldmine Record Show Calendar, May 2018</a></p>
			        			    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/unnamed-42-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/unnamed-42-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/unnamed-42-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/unnamed-42-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/unnamed-42-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/unnamed-42.jpg 450w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/news/buffalo-springfield-albums-remastered-new-box-set" title="Permalink to Buffalo Springfield albums remastered for new box set" rel="bookmark">Buffalo Springfield albums remastered for new box set</a></p>
			        			    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/Craft-Recordings-Social-Distortion-Roxy-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/Craft-Recordings-Social-Distortion-Roxy-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/Craft-Recordings-Social-Distortion-Roxy-80x80.jpg 80w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/news/craft-recordings-reissue-social-distortions-live-roxy-vinyl" title="Permalink to Craft Recordings to reissue Social Distortion&#8217;s &#8216;Live At The Roxy&#8217; on vinyl" rel="bookmark">Craft Recordings to reissue Social Distortion&#8217;s &#8216;Live At The Roxy&#8217; on vinyl</a></p>
			        			    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/Cure-Vinyl-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/Cure-Vinyl-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/Cure-Vinyl-80x80.jpg 80w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/news/cure-mixed-torn-available-june-15-rhino" title="Permalink to The Cure &#8216;Mixed Up&#8217; and &#8216;Torn Down&#8217; available June 15 from Rhino" rel="bookmark">The Cure &#8216;Mixed Up&#8217; and &#8216;Torn Down&#8217; available June 15 from Rhino</a></p>
			        			    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/beatlesHR-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/beatlesHR-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/beatlesHR-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/beatlesHR-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/beatlesHR-768x768.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/beatlesHR-1024x1024.jpg 1024w, http://wwwcdn.goldminemag.com/wp-content/uploads/beatlesHR-80x80.jpg 80w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/news/ken-sharp-releases-ultimate-dilemma-song-beatles-fans" title="Permalink to Ken Sharp releases the ultimate dilemma song for Beatles fans" rel="bookmark">Ken Sharp releases the ultimate dilemma song for Beatles fans</a></p>
			        		
			</div>

			<div class="tab-content" id="tabs2">
			<ul>

<ul>
<li>eric9321: <a href="http://www.goldminemag.com/articles/meat-loaf#comment-554793" title="on Meat Loaf — back, and braver">This is a great article, I'm s</a>...</li>
<li>zmbdog: <a href="http://www.goldminemag.com/articles/sound-advice-misprints-errors-dont-always-mean-big-bucks#comment-554788" title="on Sound Advice: Misprints, errors don't always mean big bucks">I kinda figured my Scorpions "</a>...</li>
<li>applecorp: <a href="http://www.goldminemag.com/blogs/spin-cycle-blogs/cull-record-collection#comment-554785" title="on How to cull your record collection">A majority of all RSD releases</a>...</li>
<li>applecorp: <a href="http://www.goldminemag.com/articles/magical-mystery-tour-fault-film#comment-554784" title="on Magical Mystery Tour: The fault is in the film">Jay Jay French calling somethi</a>...</li>
<li>syparrish: <a href="http://www.goldminemag.com/articles/sound-advice-misprints-errors-dont-always-mean-big-bucks#comment-554777" title="on Sound Advice: Misprints, errors don't always mean big bucks">I have a 1965 copy of Jr. Walk</a>...</li>
</ul>			</ul>
			</div>
			</div>
			<script type="text/javascript">OX_526fcbdfe7090.showAdUnit('468628');</script><br /><br /><script type="text/javascript">OX_526fcbdfe7090.showAdUnit('496016');</script><aside id="text-31" class="widget widget_text">			<div class="textwidget"><a href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_SPECIAL?ikey=K**D12&k=Uh8UJiWNaDPLZ2y0jF%2BWTawfjItALPiiDyXWgyeREJk%3D&utm_medium=email&utm_source=circulation&utm_campaign=gm-lmn-crc-180326" target="_blank"><img src="http://wwwcdn.goldminemag.com/wp-content/uploads/68off-sub-offerad.jpg"/></a></div>
		</aside> 

		</div><!-- #secondary .widget-area -->
		<div id="Offer"> <aside id="text-23" class="widget widget_text">			<div class="textwidget"><div class="left">SIGN UP for our free eNewsletter to get the latest in music collecting news and articles delivered to your inbox weekly and we'll give you.<br /><span style="color:#000;"><strong>A FREE PDF: Beatles Price Guide</strong></span></div>
<div class="right">
<!-- form here -->
</div></div>
		</aside>            <div id="et_form-div-quicksubscribe-292650" class="et-quick-subscribe et-form">
                <form id="form-quicksubscribe-292650"
                      name="form-quicksubscribe-292650" class="et_form"
                      action="/wp-content/plugins/fw-exacttarget-client/subscribe-form.php" method="POST"
                      onsubmit="return ET_LongFormSubmit('quicksubscribe-292650');">
                    <fieldset class="et_fieldset">
                        <input id="ETSubscriberKeyThxquicksubscribe-292650" name="ETSubscriberKey" type="hidden" /><input name="SubAction" type="hidden" value="sub_add_update" /><input name="formId" type="hidden" value="quicksubscribe-292650" /><ul style="list-style-type:none; margin:0; padding:0;" class="et_field_list"><li><label for="EmailAddressThx"><span class='required'>*</span>  </label><input type="text" autocomplete="off" id="EmailAddressThxquicksubscribe-292650" class="et_text" name="et_emailAddress" value="enter your email here" placeholder="enter your email here" onfocus="etEmailFocus('enter your email here',this)" onblur="if (this.value == '') {this.value = 'enter your email here';}" /></li><input type="hidden" name="et2_customField[1085723][Email Source Quick Subscribe]" value="True" class="" /><input type="hidden" name="et2_list[1085723][]" value="www.krausebooks.com" /><input type="hidden" name="et2_list[1085723][]" value="Goldmine Magazine" /><input type="hidden" name="et2_list[1085723][]" value="Goldmine Magazine eNewsletter" /><input type="hidden" name="et2_list[1085723][]" value="Goldmine Magazine Partners" /></ul><input type="hidden" id="thx312264" name="thx" value="http://www.goldminemag.com/thanks"  /><input type="hidden" id="err312264" name="err" value="http://wwww.goldminemag.com/subscribe-2/enewsletter/newsletter-error"  /><input type="hidden" name="et_emailSource" value="Main Content Site" /><input class='submit' name='submitSubscription' id='submit-quicksubscribe-292650' type='submit' value='GET MY FREE DOWNLOAD' /><div class="g-recaptcha" data-sitekey="6LdFPSgTAAAAAMofY_3o57b2wEzhNeixXonVaOlx"></div>                    </fieldset>
                    <input type="hidden" name="action" id="quicksubscribe-292650"
                           value="submitSubscription"/>
                    <input type="hidden" name="et_mid[]" value="1085723" />                </form>
            </div>
        </div>  
	
		<div id="primary">

				

					
		<h1 class="entry-title entry-header">New Music Reviews for May 2018</h1>

				<div class="entry-meta">
		Posted in <a href="http://www.goldminemag.com/blogs/" rel="category tag">Blogs</a>, <a href="http://www.goldminemag.com/blogs/power-pop-plus/" rel="category tag">Power Pop Plus</a> | Tags: <a href="http://www.goldminemag.com/tag/arthur-alexander/" rel="tag">Arthur Alexander</a>, <a href="http://www.goldminemag.com/tag/dana-countryman/" rel="tag">Dana Countryman</a>, <a href="http://www.goldminemag.com/tag/einsteins-sister/" rel="tag">Einstein's Sister</a>, <a href="http://www.goldminemag.com/tag/john-m-borack/" rel="tag">John M. Borack</a>, <a href="http://www.goldminemag.com/tag/juliana-hatfield/" rel="tag">Juliana Hatfield</a>, <a href="http://www.goldminemag.com/tag/kai-danzberg/" rel="tag">Kai Danzberg</a>, <a href="http://www.goldminemag.com/tag/lannie-flowers/" rel="tag">Lannie Flowers</a>, <a href="http://www.goldminemag.com/tag/matthew-sweet/" rel="tag">Matthew Sweet</a>, <a href="http://www.goldminemag.com/tag/michael-simmons/" rel="tag">Michael Simmons</a>, <a href="http://www.goldminemag.com/tag/mike-collins/" rel="tag">Mike Collins</a>, <a href="http://www.goldminemag.com/tag/power-pop/" rel="tag">power pop</a>, <a href="http://www.goldminemag.com/tag/power-pop-plus/" rel="tag">Power Pop Plus</a>, <a href="http://www.goldminemag.com/tag/rooftop-screamers/" rel="tag">Rooftop Screamers</a>, <a href="http://www.goldminemag.com/tag/sean-kelly/" rel="tag">Sean Kelly</a>, <a href="http://www.goldminemag.com/tag/sex-clark-five/" rel="tag">Sex Clark Five</a>, <a href="http://www.goldminemag.com/tag/spygenius/" rel="tag">Spygenius</a>, <a href="http://www.goldminemag.com/tag/the-bottle-kids/" rel="tag">The Bottle Kids</a>, <a href="http://www.goldminemag.com/tag/the-carousels/" rel="tag">The Carousels</a>, <a href="http://www.goldminemag.com/tag/the-choir/" rel="tag">The Choir</a>, <a href="http://www.goldminemag.com/tag/the-gold-needles/" rel="tag">The Gold Needles</a>, <a href="http://www.goldminemag.com/tag/the-jeremy-band/" rel="tag">The Jeremy Band</a>, <a href="http://www.goldminemag.com/tag/the-wrecking-two/" rel="tag">The Wrecking Two</a>		
			<br /><time class="entry-date" datetime="2018-05-06T03:39:06+00:00" pubdate>May 6, 2018</time> | <span class="by-author"> <span class="author vcard"><a class="url fn n" href="http://www.goldminemag.com/author/john-borack/" title="View all posts by John Borack" rel="author">John Borack</a></span></span>		</div><!-- .entry-meta -->
		
		<div class="social">
		<span class='st_twitter' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class="pinterest"><a href="http://pinterest.com/pin/create/button/?url=http://www.goldminemag.com/blogs/new-music-reviews-may-2018&media=http://www.goldminemag.com/wp-content/uploads/Goldmine_Borack_banner-4.jpg&description=New Music Reviews for May 2018 on http://www.goldminemag.com" class="pin-it-button" count-layout="none" style="width:28px; margin-bottom:-3px;">Pin It</a></span>
		<span class='st_email' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_stumbleupon' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_plusone' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_sharethis' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_ facebook' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_fblike' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		</div>

	<div class="entry-content">
		<p><img class="alignnone size-full wp-image-311663" src="http://wwwcdn.goldminemag.com/wp-content/uploads/Goldmine_Borack_banner-4.jpg" alt="" width="665" height="156" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/Goldmine_Borack_banner-4.jpg 665w, http://wwwcdn.goldminemag.com/wp-content/uploads/Goldmine_Borack_banner-4-150x35.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/Goldmine_Borack_banner-4-300x70.jpg 300w" sizes="(max-width: 665px) 100vw, 665px" /></p>
<p>Being a music journalist who dabbles in drumming can present something of a dilemma: it’s often tough for me to recommend releases I’m involved in without the dreaded “conflict of interest” charge rearing its not-so-pretty head. But this time out I’m throwing caution to the wind by hipping you to two releases that I contributed to, because I’d be doing a disservice to the artists involved &#8211; and to you, dear reader – if I kept my mouth shut about ‘em.</p>
<p><img class="alignnone size-medium wp-image-312265" src="http://wwwcdn.goldminemag.com/wp-content/uploads/sweet-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/sweet-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/sweet-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/sweet-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/sweet-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/sweet.jpg 700w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>First is the superfine compilation, <em><strong>Altered Sweet: A Tribute to Matthew Sweet</strong></em> (Futureman Records), which was helmed by Keith Klingensmith of the Legal Matters. It’s 27 tracks worth of primo M. Sweet love, with more well-known numbers from his catalog such as “We’re the Same,” “Girlfriend,” and “I’ve Been Waiting” rubbing shoulders with underheard gems such as “Falling,” “Quiet Her,” and “Heaven and Earth.” Artists who shine here are plentiful, and include Andy Reed, Simple Friend, Chris Richards &amp; the Subtractions, Greg Pope, Lisa Mychols, Michael Simmons, Nick Bertling, the Well Wishers, and the sorely underrated Elvyn – and that’s just on disc one. Disc two’s treasures come courtesy of Stabby Robot, Lannie Flowers, Cokeroque, Donny Brown, and Robyn Gibson, who brings out the melodic similarities between “I Should Never Have Let You Know” and “My Sweet Lord.” <em><strong>Altered Sweet</strong></em> is one of the finest tribute collections of the past several years, for sure.</p>
<p>&nbsp;</p>
<p><img class="alignnone size-medium wp-image-312266" src="http://wwwcdn.goldminemag.com/wp-content/uploads/simmons-300x298.jpg" alt="" width="300" height="298" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/simmons-300x298.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/simmons-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/simmons-768x763.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/simmons-1024x1017.jpg 1024w, http://wwwcdn.goldminemag.com/wp-content/uploads/simmons-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/simmons-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/simmons.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>Next is the solo debut from Michael Simmons, <strong>First Days of Summer</strong> (Crab Apple Records). Simmons is best known for his yeoman work with Southern California combos sparkle*jets U.K. and the Yorktown Lads, and here he conjures up a dozen tracks of breezy, melodically stimulating pop-rock (pretty much all by his lonesome) that’s all over the map stylistically. There’s a bit of Bacharach/Beach Boys-inspired loveliness (the wonderful title track), a dollop of SJUK-like quirkiness (“Fuzzy Green Hat”), some riffy rockstuff (“Rudderless Day”), a Rockpile-influenced bopper (“Bucket List”), a soulful, lyrically pointed number about living directly above an earthquake fault line (“It’s My Fault”), a slamming, darkly humorous rumination on death (“Dirt Nap”), and a thoughtful, sparse rumination on life (“Centre of the Spiral”). Oh, and there’s also one of the best pure pop songs of the past decade or so, “No More Girls,” which sounds like the hit single that Andy Partridge never wrote. And for a bit of fun, check out the self-explanatory, distorto-rap (!) of “EP’s are Weak,” in which Simmons answers the burning question, “Why is this fat old white dude spittin’ out rhymes?” One of the most gifted singers and multi-instrumentalists on the indie pop scene, Michael Simmons’ <em><strong>First Days of Summer</strong></em> is an album you’ll want to revisit again and again.</p>
<p>Okay, now that we’ve gotten those two recommendations out of the way, here’s some other releases that have been in rotation around here:</p>
<p><strong>KAI DANZBERG – <em>Pop-Up Radio</em></strong> (Self-Released)</p>
<p><img class="alignnone size-medium wp-image-312267" src="http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10-768x768.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10-1024x1024.jpg 1024w, http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/a0493243698_10.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>“Don’t expect me to sound like the Beatles or Jellyfish,” Kai Danzberg sings on “Welcome to the Show,” one of the standout cuts on <em><strong>Pop-Up Radio</strong></em>. Of course, he sorta does, but it’s more of an influence thing rather than any sort of overt aping. “Yes We Can” comes off like Kyle Vincent singing a late ‘60s sunshine pop tune, the vocal arrangement on “You’re the One” is a sparkling approximation of the Beach Boys, and the danceable, four-on-the-floor “Puppet on a String” is a nice change of pace.</p>
<p>Elsewhere, the slightly spacy balled “Stranger” is a winner with its tinkling harpsichord and “Space Oddity” feel, while the lyrical naughtiness of “What the F” is tempered a bit by the Queenly backing vox and some cool guitar/keyboard interplay. The power poppin’ grooviness of “Sophie” is another high point of a disc that should hit the sweet spot for many. Danzberg (who hails from Hanover, Germany) is currently in the midst of a crowdfunding campaign to get <em><strong>Pop-Up Radio</strong></em> released on vinyl. More info can be found here: <a href="http://www.startnext.com/kaidanzberg/en">www.startnext.com/kaidanzberg/en</a> <em><strong>Grade: A-</strong></em></p>
<p>&nbsp;</p>
<p><strong>DANA COUNTRYMAN &#8211; <em>The Joy of Pop</em></strong> (Sterling Swan)</p>
<p><img class="alignnone size-medium wp-image-312268" src="http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10-768x768.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10-1024x1024.jpg 1024w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2245737970_10.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>Former <em>Goldmine</em> contributor Dana Countryman’s latest release is another in a long line of excellent albums that find him making like a one-man Brill Building. Taking his musical cues from the Beach Boys, Nilsson, the Beatles, Gilbert O’Sullivan, and various ‘60s/’70s AM radio hits, the unashamedly retro <em><strong>The Joy of Pop</strong></em> is an enjoyable romp that takes the listener on a trip in Countryman’s musical wayback machine. Good stuff! <em><strong>Grade: B</strong></em></p>
<p>&nbsp;</p>
<p><strong>LANNIE FLOWERS – “Good”</strong> (SpyderPop Records)</p>
<p><img class="alignnone size-medium wp-image-312269" src="http://wwwcdn.goldminemag.com/wp-content/uploads/31906802_838243953034115_6674295962992640000_n-194x300.jpg" alt="" width="194" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/31906802_838243953034115_6674295962992640000_n-194x300.jpg 194w, http://wwwcdn.goldminemag.com/wp-content/uploads/31906802_838243953034115_6674295962992640000_n-150x232.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/31906802_838243953034115_6674295962992640000_n-97x150.jpg 97w, http://wwwcdn.goldminemag.com/wp-content/uploads/31906802_838243953034115_6674295962992640000_n.jpg 621w" sizes="(max-width: 194px) 100vw, 194px" /></p>
<p>Lannie Flowers should be considered something of a national treasure for fans of guitar-based, melodic pop music – he’s currently one of the leading practitioners of the form, and any new music from him is a cause for celebration. And there is much to celebrate as Lannie marches towards the release of his new album, <em><strong>Home</strong></em>, due to be released this fall: to whet the appetite of those waiting for the full-length, Spyderpop Records is offering a free download of a new Lannie Flowers tune every month leading up to the release of the new album.</p>
<p>Here are the details: each of these downloads is a non-LP cut, they’re available at the Spyderpop Records website for a month, and the three that have been unleashed thus far are as good as anything Flowers has ever done, which is to say they’re outstanding. The latest one (available through the end of May) is titled “Good,” and it’s got crunchy guitars, a slightly phased lead vocal, a beat-heavy chorus with stacks of vocal harmonies, and a melody that hooks the listener straightaway. Go grab it, and then wait for next month’s goodie and the release of <em><strong>Home</strong></em>. <em><strong>Grade: A</strong></em></p>
<p>&nbsp;</p>
<p><strong>JULIANA HATFIELD – J<em>uliana Hatfield Sings Olivia Newton-John</em></strong> (American Laundromat)</p>
<p><img class="alignnone size-medium wp-image-312270" src="http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10-768x768.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10-1024x1024.jpg 1024w, http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/a1806478574_10.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>Heartfelt tributes are always welcomed around these parts, especially when they arrive from out of left field like this one. Ms. Hatfield’s 14-track salute to the ‘70s/’80s hitmaking goodness that was Olivia Newton-John doesn’t futz with the original arrangements at all; sure, Juliana toughens up some of the guitars, but she still delivers ONJ’s biggies – “Have You Never Been Mellow,” “I Honestly Love You,” “Physical,” “Please Mr. Please,” etc. – the way God and John Farrar intended. It’s a rollicking good time from beginning to end, and it’s for a great cause, to boot: one dollar from the sale of each album will be donated to the Olivia Newton-John Cancer Wellness &amp; Research Centre. I miss “Let Me Be There” and “If You Love Me (Let Me Know),” but that’s really just quibbling – this is an outstanding example of nostalgia done right. <em><strong>Grade: A</strong></em></p>
<p>&nbsp;</p>
<p><strong>SPYGENIUS – <em>‘Pacephale</em></strong> (Big Stir)</p>
<p><img class="alignnone size-medium wp-image-312271" src="http://wwwcdn.goldminemag.com/wp-content/uploads/81UYGUyT0KL._SX522_-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/81UYGUyT0KL._SX522_-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/81UYGUyT0KL._SX522_-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/81UYGUyT0KL._SX522_-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/81UYGUyT0KL._SX522_-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/81UYGUyT0KL._SX522_.jpg 522w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>They’re quirky as all get out – song titles such as “And Her Snakes Were Decked with Smiles” and “The Friendly Stars That Glow” would seem to bear this out &#8211; but never at the expense of putting their snazzy melodies or trippy, tricky lyrics across. Spygenius’ entertaining <em><strong>‘Pacephale</strong></em> is a 13-song concept record originally released in 2016 by the UK quartet, and now given new life by the good folks at the fledgling Southern California-based Big Stir Records label. (Having called this a concept album, I must admit I’m not quite clear on what the actual “concept” is, but it certainly hasn’t prevented me from digging the hell out of this record.)</p>
<p>At times a bit shambolic (“Back Door Son of Man” recalls a loosey-goosey, early Robyn Hitchcock number), other times very Britpoppy (“Shall I Show You in My Mirror?” and “Heathen”), whimsical (“Eucalyptus &amp; Cigarettes”), Game Theory-like (“Get Over Yourself”) and inexplicably delightful and hopelessly catchy (“You and Me and Jiminy C”), everything here has the sweet air of psychedelia permeating the proceedings. Very nice. <em><strong>Grade: A-</strong></em></p>
<p>&nbsp;</p>
<p><strong>THE WRECKING TWO</strong> <strong>– “West Coast City”/”(The Girl’s) Unavailable”</strong> (Teensville)</p>
<p><img class="alignnone size-medium wp-image-312272" src="http://wwwcdn.goldminemag.com/wp-content/uploads/tomtxcoqnprva_600-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/tomtxcoqnprva_600-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/tomtxcoqnprva_600-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/tomtxcoqnprva_600-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/tomtxcoqnprva_600-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/tomtxcoqnprva_600.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>The names Kyler Schwartz and Jared Lekites should be familiar to most indie pop fans: Schwartz is one half of the brains behind Teensville Records (who are responsible for releasing a slew of cool ‘60s pop rarities on CD), while Lekites is a member of the most excellent The Lunar Laugh. Their collaboration as The Wrecking Two is a sunshine pop fan’s dream, with both sides of this digital-only release (can digital releases have sides?) evoking the Beach Boys, the Yellow Balloon, and others of their ilk. “West Coast City” is hooked by a very B. Wilson-like vocal refrain, while “(The Girl’s) Unavailable” features a lead vocal that sounds vaguely like some sort of cool cross between Carl Wilson and Frankie Valli. <em><strong>Grade: A-</strong></em></p>
<p>&nbsp;</p>
<p><strong>THE CAROUSELS – <em>Sail Me Home St. Clair</em></strong> (Kool Kat)</p>
<p><img class="alignnone size-full wp-image-312273" src="http://wwwcdn.goldminemag.com/wp-content/uploads/268x0w.jpg" alt="" width="268" height="268" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/268x0w.jpg 268w, http://wwwcdn.goldminemag.com/wp-content/uploads/268x0w-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/268x0w-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/268x0w-35x35.jpg 35w" sizes="(max-width: 268px) 100vw, 268px" /></p>
<p>This Scottish band describe their music as psychedelic folk/country, which basically means that at any point in time they can sounds like any iteration of the Byrds from 1964 through 1969. The harmonies on the stunning <em><strong>Sail Me Home St. Clair</strong> </em>are swoon-inducing, the songs (all penned by Roy McPherson and James Smith) are by and large gentle expressions of love and such, and the whole thing envelops the listener like a warm embrace. Don’t miss this one. <em><strong>Grade: A</strong></em></p>
<p>&nbsp;</p>
<p><strong>THE BOTTLE KIDS &#8211; <em>Let Me in On This Action</em></strong> (Rock Indiana)</p>
<p><img class="alignnone size-full wp-image-312274" src="http://wwwcdn.goldminemag.com/wp-content/uploads/BOTTLE-KIDS-2018-Let-me-in-on-this-action-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/BOTTLE-KIDS-2018-Let-me-in-on-this-action-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/BOTTLE-KIDS-2018-Let-me-in-on-this-action-300x300-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/BOTTLE-KIDS-2018-Let-me-in-on-this-action-300x300-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/BOTTLE-KIDS-2018-Let-me-in-on-this-action-300x300-35x35.jpg 35w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>Punchy power pop sounds from Eric Blakely, who wrote, performed, recorded and engineered the whole deal. “When You Come Around” would be my pick for a single, but much of this pushes the proper pleasure buttons. “Let’s Put the Power Back in Pop” namechecks Bill Pitcock IV and Larry Whitman (!), the more downcast “I Miss Her Goodbye” is highlighted by pretty harmony vocals and some keyboards that sound like they were torn from the Beatles’ ’67 playbook, and the breezy “The Only Heart That I Can See” is one of those insidiously catchy pop tunes that fans of the genre should wholly embrace. <em><strong>Grade: B</strong></em></p>
<p>&nbsp;</p>
<p><strong>ARTHUR ALEXANDER – <em>One Bar Left </em></strong>(Deadbeat)</p>
<p><img class="alignnone size-full wp-image-312275" src="http://wwwcdn.goldminemag.com/wp-content/uploads/2B2F8D71A-9119-582F-E1EE6C4D6F7B3C17.jpg" alt="" width="280" height="259" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/2B2F8D71A-9119-582F-E1EE6C4D6F7B3C17.jpg 280w, http://wwwcdn.goldminemag.com/wp-content/uploads/2B2F8D71A-9119-582F-E1EE6C4D6F7B3C17-150x139.jpg 150w" sizes="(max-width: 280px) 100vw, 280px" /></p>
<p>Arthur Alexander, the man behind semi-legendary ‘70s power pop combos The Poppees and The Sorrows, is back in the ring with a mighty fine solo effort – his first &#8211; that touches on power pop, garage, and good ‘ol rock and roll. Basically, much of <em><strong>One Bar Left</strong></em> is like taking a trip through Little Steven’s Underground Garage – cool guitar riffs fly all over the place, the drums (courtesy of Luis Herrera) smash and crash at just the right times, and the songs have the type of melodic thrust that many artists half Alexander’s age can’t muster. The title track (the “bar” in questions refers to cell phone usage, not a drinking establishment) rages right out of the gate, with Alexander unleashing some serious sonic fury. Other tracks to look out for: “Psycho-Automatic” and the playful “(She Got Me) Wang Dang Doodle” both bring the rock quite successfully; “Mary Lou, Mary Lou” is another powerfully catchy number featuring a memorable chorus and an instrumental breakdown that tosses some funk into the mix before giving way to a sharp guitar solo; “It’s You” is a sweet, Spector/Beatles-influenced ballad; and “Hard to Get” somehow manages to deftly merge the sound of the Stray Cats and “Lust for Life.”</p>
<p>More Spectorization can be found on the six-minute epic “Shot in the Heart,” which rocks like mad as well (although those clichéd gunshot sound effects could have been excised); two songs unearthed from 1983 and ’84 – the super-poppy “Can’t Get You Out of My Dream” and the roaring “Dead End Man” – both began with basic tracks recorded back in the day, and were finished off by adding plenty of power-packed guitars; and the gently acoustic “Hello Suzanne” sounds as if Ray Davies could have written and sung it in 1968. With songs stockpiled over a number of years – the synth moves on the otherwise Beatley sounding “Ecstasy” are oh so ‘80s – <em><strong>One Bar Left</strong></em> is a triumph for one of pop’s elder statesmen who can still show the kids a thing or three. <em><strong>Grade: A-</strong></em></p>
<p>&nbsp;</p>
<p><strong>EINSTEIN’S SISTER – <em>Learning Curves</em></strong> (Yummy Pop Tunes)</p>
<p><img class="alignnone size-medium wp-image-312276" src="http://wwwcdn.goldminemag.com/wp-content/uploads/51ejHuK7rVL._SY355_-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/51ejHuK7rVL._SY355_-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/51ejHuK7rVL._SY355_-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/51ejHuK7rVL._SY355_-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/51ejHuK7rVL._SY355_-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/51ejHuK7rVL._SY355_.jpg 355w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>Now available on vinyl, Einstein&#8217;s Sister&#8217;s 1998 album <em><strong>Learning Curves</strong></em> is one of the great lost indie pop albums of the &#8217;90s &#8211; eclectic, familiar, and deeply satisfying. It’s brimming with song after song of melodic perfection from the songwriting team of Bill Douglas, Kerry Tucker and company, with passionate lead vocals, ace instrumentation (big kudos to drummer Marty Reyhons), and sparkling production helping to bring the tunes to life. Bookended by the fab 1-2 power pop punch of &#8220;Jealous Time&#8221; (on the short list of my fave songs of the past couple of decades) and &#8220;Memory Waiting to Happen,&#8221; there&#8217;s also a bit of country here, a sweet ballad there, an awesome acoustic ditty (&#8220;No Laughing Matter&#8221; can be seen as a darker cousin to the Beatles&#8217; &#8220;I&#8217;ve Just Seen a Face&#8221;), and a boatload of other wonderful numbers.</p>
<p><em><strong>Learning Curves</strong></em> is something of an irresistible record, really, with many inventive little instrumental and production touches (the backwards guitar on &#8220;Together We&#8217;re Alone&#8221; is so fresh sounding, you&#8217;d think these guys were the first to add it to their record) and some classy arrangements, as well. A major league winner, and an LP you need to add to your collection. (It’s a Limited Edition Deluxe 20th Anniversary Issue, remastered and pressed on yellow vinyl with a bonus 7&#8243; single on clear vinyl, a hi-res download card, lyric sheet, and a bonus instrumental and rarities CD. Whew!) <em><strong>Grade: A</strong></em></p>
<p>&nbsp;</p>
<p><strong>SEX CLARK FIVE – <em>Ghost Brigade</em></strong> (Records to Russia)</p>
<p><img class="alignnone size-medium wp-image-312277" src="http://wwwcdn.goldminemag.com/wp-content/uploads/sexclarkfive-300x272.jpg" alt="" width="300" height="272" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/sexclarkfive-300x272.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/sexclarkfive-150x136.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/sexclarkfive-768x697.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/sexclarkfive-1024x929.jpg 1024w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>SC5’s Rick Storey: “We don’t play ‘rock’ music! We play rock ‘n’ roll, power pop, punk, skate, speed, grunge or gurgle. We play Strum and Drum Music!” Well, yes and no. While there is plenty of vintage SC5 strumming and drumming happening on the oddly captivating <em><strong>Ghost Brigade</strong></em>, there are still moments where the Alabama-based combo veers into power pop – along with a weirdo march (“Dr. Jung”), a bit of arty something-something (“Father Joe”), a cool little tune that borrows the main riff from the Music Machine’s “Talk Talk” (“Christmas Truce”), and an insistently catchy, synth-fueled ditty (“Apotheosis”). But the upbeat strum and drum stuff is where the 23-song disc really takes flight, and there’s plenty of that here.</p>
<p><em><strong>Ghost Brigade</strong></em> is a rock opera of sorts “about a girl who becomes a goddess,” says SC5’s James Butler, and as such comes complete with a libretto detailing the adventures of characters such as Raymond and Christabel, Captain Abilene, and Cigarette Burns. So while the tunes may be sort of all over the place (I didn’t hear any grunge, thankfully), the saga is certainly a musically fruitful one – personal faves are the catchy-as-hell “Mercenary Massacre” and “Lightning Raid.” And yes, there is a bit of gurgle, too, as well as this unforgettable turn of a phrase: “Cigarette Burns was a Yankee/He got his start with a wiener cart/Selling tainted meat to the spankys/All the rascals were very cranky.” <em><strong>Grade: A-</strong></em></p>
<p>&nbsp;</p>
<p><strong>THE CHOIR – <em>Artifact: The Unreleased Album</em></strong> (Omnivore)</p>
<p><img class="alignnone size-medium wp-image-312278" src="http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263-768x768.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263-1024x1024.jpg 1024w, http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/Choir-Artifact-OV-263.jpg 1500w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>Here we have the album that never was by ‘60s Cleveland pop-rock legends The Choir, recorded in February 1969 by one of their several post-“It’s Cold Outside” lineups. It’s less overtly poppy than that earlier material, with some sonic tips of the hat to contemporaries such as Cream, the Left Banke, Procol Harum, the Bee Gees, and the Kinks. (They faithfully cover “David Watts” to great effect here, less than two years after Ray Davies and company released it.)</p>
<p>Some of the songs get a bit “jammy” at times (“Have I No Love to Offer,” the instrumental “For Eric”), others are quite pretty (“It’s All Over”), and there’s even an old timey, music hall-styled choon (“Mummer Band”). The hooky “Anyway I Can” still sounds vital nearly 50 years after the fact, thanks in large part to future Raspberries drummer Jim Bonfanti’s nimble stickwork; it’s one of the four tunes here that has been previously released. Kudos to Tommy Allen (mixing) and Ducky Carlisle (mastering) for doing their part to make these ten artifacts sound absolutely fresh. <em><strong>Grade: B+</strong></em></p>
<p>&nbsp;</p>
<p><strong>THE GOLD NEEDLES – <em>Pearls</em></strong> (Kool Kat)</p>
<p><img class="alignnone size-medium wp-image-312279" src="http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10-768x769.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10-1024x1024.jpg 1024w, http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/a3306394790_10.jpg 1199w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>A generous 18-track collection from this UK trio, whose dense, often thick-sounding guitars sometimes belie their sunny melodies. The first two tracks “Pearls” and “Not Tonight Josephine” are instantly memorable pop songs, while “Daydreamer’s Song” is one of the most thoughtful, gorgeous tunes I’ve had the pleasure of hearing in 2018. Some of the tracks take a slightly more prog-rock approach, there are a few instrumentals sprinkled in for flavor (“Service with a Smile” is a particularly good’un), and many of the tracks seem to carry an unspoken undercurrent of melancholy. A solid debut. <em><strong>Grade: B</strong></em></p>
<p>&nbsp;</p>
<p><strong>THE JEREMY BAND – <em>Joy Comes in the Morning</em></strong> (JAM)</p>
<p><img class="alignnone size-full wp-image-312280" src="http://wwwcdn.goldminemag.com/wp-content/uploads/jeremyjoycomes.jpg" alt="" width="210" height="210" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/jeremyjoycomes.jpg 210w, http://wwwcdn.goldminemag.com/wp-content/uploads/jeremyjoycomes-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/jeremyjoycomes-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/jeremyjoycomes-35x35.jpg 35w" sizes="(max-width: 210px) 100vw, 210px" /></p>
<p>A new Jeremy Morris release is much like the taxman coming on April 15th (although a much more pleasant experience, of course): you know it’s coming and resistance is futile. <em><strong>Joy Comes in the Morning</strong> </em>is one of his finest, most cohesive records to date, and collects another dozen chipper, jangly, unfailingly pleasant-sounding Morris compositions that are lyrically positive and uplifting and difficult to dislike. (Jeremy shreds on lead guitar more than a few times as well.) A couple of the tunes feature “Now where have I heard that riff before?” moments – it took me a while to suss out that one particular guitar figure here is similar to Warren Zevon’s “Poor Poor Pitiful Me” – but that’s really just part of Jeremy’s charm.</p>
<p>Morris is ably backed here by his band: steady-as-she-goes drummer Dave Dietrich and bassist Todd Borsch, who sadly (and unexpectedly) passed away just as <em><strong>Joy in the Morning </strong></em>was released. Listening to the lyrically spiritual and beautifully constructed piano/acoustic guitar ballad “Sudden Grace” in the wake of this devastating news is both horribly sad and somehow healing. Rest in peace, Todd. <em><strong>Grade: B+</strong></em></p>
<p>&nbsp;</p>
<p><strong>SEAN KELLY – <em>Time Bomb, Baby</em></strong> (MPress)</p>
<p><img class="alignnone size-medium wp-image-312281" src="http://wwwcdn.goldminemag.com/wp-content/uploads/Sean_Kelly_-_Time_Bomb_1024x1024-300x300.jpg" alt="" width="300" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/Sean_Kelly_-_Time_Bomb_1024x1024-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/Sean_Kelly_-_Time_Bomb_1024x1024-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/Sean_Kelly_-_Time_Bomb_1024x1024-768x768.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/Sean_Kelly_-_Time_Bomb_1024x1024-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/Sean_Kelly_-_Time_Bomb_1024x1024-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/Sean_Kelly_-_Time_Bomb_1024x1024.jpg 1024w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>This was released late in 2017, but I didn’t want to let any more time go by without mentioning what a fine record it is. A member of Southern indie-pop stalwarts A Fragile Tomorrow, Sean Kelly’s solo bow is a 180-degree turn from his work with his band: <em><strong>Time Bomb, Baby</strong></em> is densely constructed, multi-layered, challenging, powerful, and sometimes even danceable (“In America”). Most of the 11 tracks have a sort of European feel to ‘em, with guitars, synths, drum machines and some left-field percussive sounds dotting the musical landscape. (A wonderfully spacy cover of Peter Holsapple’s “No Sound” features all of the above.) Tracks such as “The Light” feature more of a harder edge, while others such as the otherworldly, tribal-sounding “Let Me Be the First to Find Out,” “Poughkeepsie,” “We’re Getting Older, Brother” and “You Started It” are both soulful and hypnotic, with Kelly’s assured lead vocals sitting on top of the always ear-catching instrumental beds. A unique and special record. <em><strong>Grade: A-</strong></em></p>
<p>&nbsp;</p>
<p><strong>ROOFTOP SCREAMERS – <em>Volume 1</em></strong> (Self-Released)</p>
<p><img class="alignnone size-medium wp-image-312282" src="http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10-291x300.jpg" alt="" width="291" height="300" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10-291x300.jpg 291w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10-150x155.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10-768x791.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10-994x1024.jpg 994w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10-146x150.jpg 146w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/a2733218692_10.jpg 1165w" sizes="(max-width: 291px) 100vw, 291px" /></p>
<p>The latest project from drummer/songwriter Mike Collins (formerly of Throwback Suburbia), Rooftop Screamers is a vehicle that showcases his sturdy original tunes, each sung by a different lead vocalist. <em><strong>Volume 1</strong></em> includes eight songs, and while Kyle Vincent and Ken Stringfellow are the names you’ll recognize – and their guest vocal shots are both excellent &#8211; there are other tracks to recommend as well. “Have Mercy,” sung by Geoff Metts, is an Americana-tinged rocker with a soaring chorus, and “I Belong” (with Bob Byers on vocals) is a nice little rocker that wouldn’t sound out of place on AOR radio. “Talk About It,” with Rob Daiker at the mic, is another mid-tempo winner that’s worthy of your attention. It&#8217;s available on Bandcamp and other digital platforms, where you can cherry-pick the tunes that tickle your fancy or spring for the whole shebang. <em><strong>Grade: B+</strong></em></p>
<p>&nbsp;</p>
				<div class="social">
		<span class='st_twitter' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class="pinterest"><a href="http://pinterest.com/pin/create/button/?url=http://www.goldminemag.com/blogs/new-music-reviews-may-2018&media=http://www.goldminemag.com/wp-content/uploads/Goldmine_Borack_banner-4.jpg&description=New Music Reviews for May 2018 on http://www.goldminemag.com" class="pin-it-button" count-layout="none" style="width:28px; margin-bottom:-3px;">Pin It</a></span>
		<span class='st_email' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_stumbleupon' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_plusone' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_sharethis' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_ facebook' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		<span class='st_fblike' st_title='New Music Reviews for May 2018' st_url='http://www.goldminemag.com/blogs/new-music-reviews-may-2018' ></span>
		</div>
			</div><!-- .entry-content -->

		
</article><!-- #post-312264 -->

						<div id="comments">
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blogs/new-music-reviews-may-2018#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://www.goldminemag.com/login/?redirect_to=http%3A%2F%2Fwww.goldminemag.com%2Fblogs%2Fnew-music-reviews-may-2018">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments -->

				

		</div><!-- #primary -->


	</div><!-- #main -->

	<footer id="colophon" role="contentinfo">

			
<div id="supplementary" class="two">
		<div id="first" class="widget-area" role="complementary">
		<aside id="text-24" class="widget widget_text">			<div class="textwidget"><div id="glinks" style="margin-left: 20px;">
 <h4>Advertisement</h4>

<script type="text/javascript"><!--
google_ad_client = "ca-pub-9670108431615045";
/* GMN300x250Box */
google_ad_slot = "4326084613";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div>
		</aside><aside id="text-29" class="widget widget_text">			<div class="textwidget"><a href="http://cygnusradio.com/category/goldmine-radio-hour/"><img src="http://wwwcdn.goldminemag.com/wp-content/uploads/goldmine-radio-hour-new.jpg"/></a></div>
		</aside><aside id="text-30" class="widget widget_text">			<div class="textwidget"><div id="splinks" style="margin-left: 20px;">
<h4>Sponsored Links</h4>

<a href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B04">Discover the Music Collector's Magazine</a>
<p>Receive 14 Issues for just $25.95</p>

<a href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B05">Save 60% off the Newsstand Price</a>
<p>When You Subscribe to Goldmine Today!</p>

<a href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B06">Try a Digital Subscription of Goldmine</a>
<p>$19.99 Worldwide Rate</p>

<a href="https://ssl.palmcoastd.com/07639/apps/DIGITAL?ikey=I**C10">Take Goldmine on the Go</a>
<p>Now Available in Digital Format</p>

<a href="http://www.goldminemag.com/collector-resources/record-show-calendar/">Record Show Calendar</a>
<p>See a complete show schedule</p>

</div></div>
		</aside>	</div><!-- #first .widget-area -->
	
		<div id="second" class="widget-area" role="complementary">
		<aside id="text-21" class="widget widget_text">			<div class="textwidget"><img src="http://wwwcdn.goldminemag.com/wp-content/uploads/GM_Logo_black-1.png" /> <a href="/about-us">About Us</a> | <a href="/advertise">Advertising Information</a> | <a href="http://www.fwmedia.com/privacy" target="_blank">Privacy Policy</a> <span style="float:right;">&copy; <script>document.write(new Date().getFullYear());</script>  <a href="http://www.fwmedia.com" target="_blank">F+W</a> All rights reserved. </span></div>
		</aside>	</div><!-- #second .widget-area -->
	
	</div><!-- #supplementary -->

	</footer><!-- #colophon -->
</div><!-- #page -->
<script type="text/javascript" src="http://assets.pinterest.com/js/pinit.js"></script>

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5LJFPS"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/wpaudio-mp3-player/wpaudio.min.js?ver=3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.goldminemag.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.8'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>

<script type="text/javascript">
if(typeof _satellite !== "undefined"){
  _satellite.pageBottom();
}
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"7c6878bca9","applicationID":"42845558","transactionName":"YwFSYBBQXhdVUkRYWlpLcVcWWF8KG0JZX1JYAQ==","queueTime":0,"applicationTime":162,"atts":"T0ZRFlhKTRk=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>