<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 9]>
<html id="ie9" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1026.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="p:domain_verify" content="8a90d12ecbe7457c3470670736676383" /> 


<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="http://wwwcdn.goldminemag.com/wp-content/themes/goldmine-mag-theme/style.css" />
<link rel="pingback" href="http://www.goldminemag.com/xmlrpc.php" />
<link rel="shortcut icon" href="/favicon.ico" />

<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.2/jquery.min.js"></script>
<script type="text/javascript">
<!--
$(document).ready(function() {
 
	$('.tabs a').click(function(){
		switch_tabs($(this));
	});
 
	switch_tabs($('.defaulttab'));
 
});
 
function switch_tabs(obj)
{
	$('.tab-content').hide();
	$('.tabs a').removeClass("selected");
	var id = obj.attr("rel");
 
	$('#'+id).show();
	obj.addClass("selected");
}
//-->
</script>
<!--[if lt IE 9]>
<script src="http://wwwcdn.goldminemag.com/wp-content/themes/goldmine-mag-theme/js/html5.js" type="text/javascript"></script>
<![endif]-->

<!-- This site is optimized with the Yoast SEO plugin v4.7 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Live, Rundgren is still a wizard, a true star - Goldmine Magazine</title>
<meta name="description" content="With much of the so-called “Hot Toddies” tour set list culled from that new album, the concert deemphasized the obvious hits but it was well worth the draw."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star" />
<link rel="publisher" href="https://plus.google.com/105853805944722221195/posts"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Live, Rundgren is still a wizard, a true star - Goldmine Magazine" />
<meta property="og:description" content="With much of the so-called “Hot Toddies” tour set list culled from that new album, the concert deemphasized the obvious hits but it was well worth the draw." />
<meta property="og:url" content="http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star" />
<meta property="og:site_name" content="Goldmine Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/goldminemag" />
<meta property="article:tag" content="Todd Rundgren" />
<meta property="article:section" content="Concert Reviews" />
<meta property="article:published_time" content="2017-06-05T16:04:04-05:00" />
<meta property="og:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren.jpg" />
<meta property="og:image:width" content="875" />
<meta property="og:image:height" content="1280" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="With much of the so-called “Hot Toddies” tour set list culled from that new album, the concert deemphasized the obvious hits but it was well worth the draw." />
<meta name="twitter:title" content="Live, Rundgren is still a wizard, a true star - Goldmine Magazine" />
<meta name="twitter:site" content="@goldmine_mag" />
<meta name="twitter:image" content="http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren.jpg" />
<meta name="twitter:creator" content="@goldmine_mag" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.goldminemag.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Goldmine Magazine &raquo; Feed" href="http://www.goldminemag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Goldmine Magazine &raquo; Comments Feed" href="http://www.goldminemag.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Goldmine Magazine &raquo; Live, Rundgren is still a wizard, a true star Comments Feed" href="http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/wwwcdn.goldminemag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='theme-my-login-css'  href='http://wwwcdn.goldminemag.com/wp-content/plugins/theme-my-login/theme-my-login.css?ver=6.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='st-widget-css'  href='http://wwwcdn.goldminemag.com/wp-content/plugins/share-this/css/style.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://wwwcdn.goldminemag.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.3' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('http://wwwcdn.goldminemag.com/wp-content/plugins/wp-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wp-form-css'  href='http://wwwcdn.goldminemag.com/wp-content/plugins/fw-exacttarget-forms/css/frontend.form.css?ver=0.1.0' type='text/css' media='screen' />
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.6.1'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/theme-my-login/modules/themed-profiles/themed-profiles.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/fw-exacttarget-forms/js/et_onsubmit.js?ver=4.7.4'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?onload=etCaptchaInit&#038;render=explicit&#038;ver=4.7.4'></script>
<link rel='https://api.w.org/' href='http://www.goldminemag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.goldminemag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://wwwcdn.goldminemag.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='http://www.goldminemag.com/?p=309962' />
<link rel="alternate" type="application/json+oembed" href="http://www.goldminemag.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.goldminemag.com%2Freviews%2Flive-rundgren-still-wizard-true-star" />
<link rel="alternate" type="text/xml+oembed" href="http://www.goldminemag.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.goldminemag.com%2Freviews%2Flive-rundgren-still-wizard-true-star&#038;format=xml" />
<!-- OpenX header script -->
                   <script type="text/javascript" src="http://fwmedia-d.openx.net/w/1.0/jstag"></script>
                   <script type="text/javascript">
                     var OX_526fcbdfe7090 = OX();
                     OX_526fcbdfe7090.addVariable("kw", "cat34031,cat1,post309962,tag31171")
                     OX_526fcbdfe7090.addPage("16756");
                     OX_526fcbdfe7090.fetchAds();
                   </script>
                   <!-- end generated tag --><!-- Category Reference
Category 34031 = Concert Reviews
Category 1 = Reviews
Tag 31171 = Todd Rundgren
-->
<script charset="utf-8" type="text/javascript">var switchTo5x=true;</script><script charset="utf-8" type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script><script type="text/javascript">stLight.options({publisher:'wp.784b3f5d-3209-45fd-90e8-0c08e8a66cba', onhover: false});var st_type='wordpress3.2.1';</script><script type='text/javascript'>/* <![CDATA[ */ var _wpaudio = {url: 'http://wwwcdn.goldminemag.com/wp-content/plugins/wpaudio-mp3-player', enc: {}, convert_mp3_links: false, style: {text_font:'Sans-serif',text_size:'18px',text_weight:'normal',text_letter_spacing:'normal',text_color:'inherit',link_color:'#24f',link_hover_color:'#02f',bar_base_bg:'#eee',bar_load_bg:'#ccc',bar_position_bg:'#46f',sub_color:'#aaa'}}; /* ]]> */</script>
<!-- Google Tag Manager for WordPress by DuracellTomi - http://duracelltomi.com -->
<script data-cfasync="false" type="text/javascript">
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
	dataLayer.push({"pagePostType":"post","pagePostType2":"single-post","pageCategory":["concert-reviews","reviews"],"pageAttributes":["todd-rundgren"],"pagePostAuthor":"Goldmine1"});
</script>
<script data-cfasync="false">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5LJFPS');</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by DuracellTomi --><script type="text/javascript" src="http://wwwcdn.goldminemag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1496714170"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->
</head>

<body class="post-template-default single single-post postid-309962 single-format-standard singular two-column right-sidebar">
<div id="page" class="hfeed">
	<header id="branding" role="banner">
			<hgroup>
							<span id="site-title">Goldmine Magazine</span>
						</hgroup>

			<a href="/" alt="Goldmine Magazine" /><img class="logo" src="http://wwwcdn.goldminemag.com/wp-content/uploads/goldmine-logo.jpg" /></a>

			<script type="text/javascript">OX_526fcbdfe7090.showAdUnit('468627');</script>
			<nav id="access" role="navigation">
				<h3 class="assistive-text">Main menu</h3>
								<div class="skip-link"><a class="assistive-text" href="#content" title="Skip to primary content">Skip to primary content</a></div>
				<div class="skip-link"><a class="assistive-text" href="#secondary" title="Skip to secondary content">Skip to secondary content</a></div>
								<div class="menu-top-navigation-container"><ul id="menu-top-navigation" class="menu"><li id="menu-item-266851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-266851"><a href="http://www.goldminemag.com/articles/">Articles</a>
<ul class="sub-menu">
	<li id="menu-item-266861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-266861"><a href="http://www.goldminemag.com/news/">News</a>
	<ul class="sub-menu">
		<li id="menu-item-267031" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267031"><a href="http://www.goldminemag.com/news/obituaries-news/">Obituaries</a></li>
		<li id="menu-item-266881" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266881"><a href="http://www.goldminemag.com/news/disc-news/">Disc News</a></li>
		<li id="menu-item-267021" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267021"><a href="http://www.goldminemag.com/news/music-news/">Music News</a></li>
		<li id="menu-item-266871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266871"><a href="http://www.goldminemag.com/news/artist-news/">Artist News</a></li>
		<li id="menu-item-267041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267041"><a href="http://www.goldminemag.com/news/tour-news-news/">Tour News</a></li>
	</ul>
</li>
	<li id="menu-item-309164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-309164"><a href="http://www.goldminemag.com/articles/10-albums-that-changed-my-life/">10 Albums</a></li>
	<li id="menu-item-267331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267331"><a href="http://www.goldminemag.com/collector-resources/for-the-record/">For The Record</a></li>
	<li id="menu-item-266951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266951"><a href="http://www.goldminemag.com/articles/high-fidelity/">High Fidelity</a></li>
	<li id="menu-item-266931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266931"><a href="http://www.goldminemag.com/articles/discoveries/">Discoveries</a></li>
	<li id="menu-item-266971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266971"><a href="http://www.goldminemag.com/articles/flashback/">Flashback</a></li>
	<li id="menu-item-267341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267341"><a href="http://www.goldminemag.com/articles/rock-and-roll-hall-of-fame/">Rock And Roll Hall Of Fame</a></li>
	<li id="menu-item-266991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266991"><a href="http://www.goldminemag.com/articles/where-are-they-now-article/">Where Are They Now?</a></li>
	<li id="menu-item-266981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266981"><a href="http://www.goldminemag.com/articles/sounding-off/">Sounding Off</a></li>
	<li id="menu-item-266961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266961"><a href="http://www.goldminemag.com/articles/readers-choice/">Readers&#8217; Choice</a></li>
	<li id="menu-item-266921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266921"><a href="http://www.goldminemag.com/articles/backstage-pass-article/">Backstage Pass</a></li>
</ul>
</li>
<li id="menu-item-267051" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-267051"><a href="http://www.goldminemag.com/reviews/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-267061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267061"><a href="http://www.goldminemag.com/reviews/album-reviews/">Album Reviews</a></li>
	<li id="menu-item-267081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267081"><a href="http://www.goldminemag.com/reviews/blu-ray-reviews/">Blu-ray Reviews</a></li>
	<li id="menu-item-267101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267101"><a href="http://www.goldminemag.com/reviews/best-live-albums/">Best Live Albums</a></li>
	<li id="menu-item-267091" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-267091"><a href="http://www.goldminemag.com/reviews/concert-reviews/">Concert Reviews</a></li>
	<li id="menu-item-267071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267071"><a href="http://www.goldminemag.com/reviews/dvd-reviews/">DVD Reviews</a></li>
	<li id="menu-item-267111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267111"><a href="http://www.goldminemag.com/reviews/book-reviews/">Book Reviews</a></li>
</ul>
</li>
<li id="menu-item-267171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-267171"><a href="http://www.goldminemag.com/goldmine_hof/">Goldmine Hall of Fame</a>
<ul class="sub-menu">
	<li id="menu-item-267181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267181"><a href="http://www.goldminemag.com/goldmine_hof/goldmine_hof_articles/">Goldmine Hall of Fame Articles</a></li>
	<li id="menu-item-267191" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267191"><a href="http://www.goldminemag.com/goldmine_hof/goldmine_hof_criteria/">Goldmine Hall of Fame Criteria</a></li>
	<li id="menu-item-267201" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267201"><a href="http://www.goldminemag.com/goldmine_hof/goldmine_hof_inductees/">Goldmine Hall of Fame Inductees</a></li>
</ul>
</li>
<li id="menu-item-266891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-266891"><a href="http://www.goldminemag.com/blogs/">Blogs</a>
<ul class="sub-menu">
	<li id="menu-item-267131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267131"><a href="http://www.goldminemag.com/blogs/american-back-roads-blogs/">American Back Roads</a></li>
	<li id="menu-item-267141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267141"><a href="http://www.goldminemag.com/blogs/california-60s/">California 60s</a></li>
	<li id="menu-item-293412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293412"><a href="http://www.goldminemag.com/blogs/filled-with-sound/">Filled With Sound</a></li>
	<li id="menu-item-267121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267121"><a href="http://www.goldminemag.com/blogs/great-blogs-of-fire/">Great Blogs Of Fire</a></li>
	<li id="menu-item-306705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-306705"><a href="http://www.goldminemag.com/blogs/indie-showcase/">Indie Showcase</a></li>
	<li id="menu-item-267151" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267151"><a href="http://www.goldminemag.com/blogs/power-pop-plus/">Power Pop Plus</a></li>
	<li id="menu-item-294305" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294305"><a title="Spin Cycle Blog" href="http://www.goldminemag.com/blogs/">Spin Cycle Blog</a></li>
	<li id="menu-item-266901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266901"><a href="http://www.goldminemag.com/blogs/sounds-from-across-the-pond/">Sounds From Across The Pond</a></li>
	<li id="menu-item-308575" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-308575"><a href="http://www.goldminemag.com/blogs/vinyl-finds/">Vinyl Finds</a></li>
</ul>
</li>
<li id="menu-item-267211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-267211"><a href="http://www.goldminemag.com/collector-resources/">Music Collector Resources</a>
<ul class="sub-menu">
	<li id="menu-item-271071" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271071"><a href="http://www.goldminemag.com/record-store-directory/">Record Stores</a></li>
	<li id="menu-item-267451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267451"><a href="http://www.goldminemag.com/collector-resources/record-grading/">Record Grading</a></li>
	<li id="menu-item-267471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267471"><a href="http://www.goldminemag.com/collector-resources/record-store-day/">Record Store Day</a></li>
	<li id="menu-item-267461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267461"><a href="http://www.goldminemag.com/collector-resources/record-show-calendar/">Record Show Calendar</a></li>
	<li id="menu-item-308573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-308573"><a href="http://www.goldminemag.com/collector-resources/record-store-recon/">Record Store Recon</a></li>
	<li id="menu-item-267231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-267231"><a href="http://www.goldminemag.com/collector-resources/collectors-corner-collector-resources/">Collector&#8217;s Corner</a>
	<ul class="sub-menu">
		<li id="menu-item-267221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267221"><a href="http://www.goldminemag.com/collector-resources/collector-supplies/">Collector Supplies</a></li>
		<li id="menu-item-267241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267241"><a href="http://www.goldminemag.com/collector-resources/collectors-voice/">Collector&#8217;s Voice</a></li>
		<li id="menu-item-267261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267261"><a href="http://www.goldminemag.com/collector-resources/want-lists/">Want Lists</a></li>
		<li id="menu-item-267271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267271"><a href="http://www.goldminemag.com/collector-resources/sound-advice-collector-resources/">Sound Advice</a></li>
		<li id="menu-item-267281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267281"><a href="http://www.goldminemag.com/collector-resources/our-readers/">Our Readers</a></li>
		<li id="menu-item-267321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267321"><a href="http://www.goldminemag.com/collector-resources/for-the-record/">For The Record</a></li>
		<li id="menu-item-267291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267291"><a href="http://www.goldminemag.com/collector-resources/beyond-vinyl/">Beyond Vinyl</a></li>
		<li id="menu-item-267301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-267301"><a href="http://www.goldminemag.com/collector-resources/market-watch/">Market Watch</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-267481" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267481"><a href="http://www.goldminemag.com/giveaway/">Giveaway</a></li>
<li id="menu-item-267491" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-267491"><a target="_blank" href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B02">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-267511" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267511"><a title="Get a VIP Subscription" href="http://www.goldminemag.com/subscribe-2/v-i-p/">All Access VIP Subscription</a></li>
	<li id="menu-item-292315" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-292315"><a title="Choose between paper and PDF" target="_blank" href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B03">Goldmine Magazine Print OR Digital Subscription</a></li>
	<li id="menu-item-295890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-295890"><a title="Goldmine Subscription: Easy, affordable, appreciated" target="_blank" href="https://ssl.palmcoastd.com/07639/apps/GFTOPTION1LANDING?ikey=I**BG1">Give a Gift</a></li>
	<li id="menu-item-267501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267501"><a title="Watch out for fraudulent mailings" href="http://www.goldminemag.com/subscribe-2/alert/">Subscription Fraud Alert!</a></li>
	<li id="menu-item-267541" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-267541"><a title="FREE news and updates" href="http://www.goldminemag.com/subscribe-2/enewsletter/">Get Our eNewsletter</a></li>
</ul>
</li>
<li id="menu-item-306548" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-306548"><a href="http://www.goldminemag.com/about-us/">About</a>
<ul class="sub-menu">
	<li id="menu-item-306549" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306549"><a href="http://www.goldminemag.com/about-us/">About Goldmine Magazine and How to Contact Us</a></li>
	<li id="menu-item-306547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-306547"><a href="http://www.goldminemag.com/advertise/">Advertise</a></li>
</ul>
</li>
<li id="menu-item-266811" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-266811"><a target="_blank" href="http://www.krausebooks.com/category/records?lid=gmnnav3&#038;r=gmnnav3#new_tab">Shop</a>
<ul class="sub-menu">
	<li id="menu-item-266841" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-266841"><a target="_blank" href="http://www.krausebooks.com/category/records-price-guides?lid=gmpphm022311priceguides&#038;r=gmpphm022311priceguides#new_tab">Price Guides</a></li>
	<li id="menu-item-267551" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267551"><a href="http://www.krausebooks.com/records-cd-dvd">CD/DVDs &#038; Download Resources</a></li>
	<li id="menu-item-266821" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-266821"><a target="_blank" href="http://www.krausebooks.com/category/records?lid=gmpphm022311recordsvinyl&#038;r=gmpphm022311recordsvinyl#new_tab">Records &#038; Vinyl</a></li>
	<li id="menu-item-266831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-266831"><a href="http://www.goldminemag.com/shop/webinars/">Webinars</a></li>
	<li id="menu-item-267561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267561"><a href="http://www.krausebooks.com/rock-n-roll-artists">Rock &#8216;n&#8217; Roll Books</a></li>
</ul>
</li>
</ul></div>			</nav><!-- #access -->
	</header><!-- #branding -->

	<div id="main">
		<div id="secondary" class="widget-area" role="complementary">

			<div id="admin">



				<form method="get" id="searchform" action="http://www.goldminemag.com/">
		<label for="s" class="assistive-text">Search</label>
		<input type="text" class="field" name="s" id="s" value="Search GoldmineMag" onfocus="if (this.value == 'Search GoldmineMag') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search GoldmineMag';}" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
	</form>
 

			<div id="userLinks">
			                            		
			<a href="http://www.goldminemag.com/login?action=register">Register</a> 
			<a href="http://www.goldminemag.com/login">Log In</a>
						</div>

			<div id="socialLinks">
			<a href="https://www.facebook.com/goldminemag/" alt="Goldmine Magazine on Facebook" target="_blank" style="background-position:-32px 0;" >&nbsp;</a> 
			<a href="http://twitter.com/Goldmine_mag" alt="Goldmine Magazine on Twitter" target="_blank" style="background-position:-2px 0;" >&nbsp;</a> 		
			<a href="http://www.myspace.com/goldmine.magazine" alt="Goldmine Magazine Myspace" style="background-position:-63px 0;" target="_blank">&nbsp;</a> 
			<a href="http://www.youtube.com/user/GoldmineMagVideo" alt="Goldmine Magazine on YouTube" style="background-position:-95px 0;" target="_blank">&nbsp;</a> 
			<a href="http://feeds.feedburner.com/GoldmineMagazine" alt="Goldmine Magazine RSS" style="background-position:-127px 0;"  target="_blank">&nbsp;</a>
            			<a href="http://pinterest.com/goldminemag" alt="Goldmine Magazine Pinterest" style="background-position:-158px 0;"  target="_blank">&nbsp;</a>
			</div>
			</div>

			<div id="tabSection" style="margin:115px 0 20px 0;">
			<ul class="tabs">
        		<li><a class="defaulttab" rel="tabs1">News</a></li>
        		<li><a rel="tabs2">Recent Comments</a></li>
    			</ul>

			<div class="tab-content" id="tabs1">

				    						    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/beatles-grossman-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/beatles-grossman-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/beatles-grossman-80x80.jpg 80w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/collector-resources/paddle8-celebrates-beatles-online-auction" title="Permalink to Paddle8 celebrates The Beatles with online auction" rel="bookmark">Paddle8 celebrates The Beatles with online auction</a></p>
			        			    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/Doors-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/Doors-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/Doors-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/Doors-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/Doors-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/Doors.jpg 450w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/news/doors-commemorate-light-fire-50th-replica-7-inch" title="Permalink to Doors commemorate &#8220;Light My Fire&#8221; 50th with replica 7-inch" rel="bookmark">Doors commemorate &#8220;Light My Fire&#8221; 50th with replica 7-inch</a></p>
			        			    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/SegerGreatesthits-Crop-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/SegerGreatesthits-Crop-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/SegerGreatesthits-Crop-80x80.jpg 80w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/news/bob-seger-greatest-hits-ramblin-gamblin-man-vinyl" title="Permalink to Bob Seger &#8220;Greatest Hits&#8221; and &#8220;Ramblin’ Gamblin’ Man&#8221; to come out on vinyl" rel="bookmark">Bob Seger &#8220;Greatest Hits&#8221; and &#8220;Ramblin’ Gamblin’ Man&#8221; to come out on vinyl</a></p>
			        			    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/gregg-allman-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/gregg-allman-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/gregg-allman-80x80.jpg 80w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/articles/gregg-allman-angelic-road" title="Permalink to Gregg Allman&#8217;s angelic road" rel="bookmark">Gregg Allman&#8217;s angelic road</a></p>
			        			    		<p><img width="35" height="35" src="http://wwwcdn.goldminemag.com/wp-content/uploads/95-1-35x35.jpg" class="attachment-news-sidebar-thumbnail size-news-sidebar-thumbnail wp-post-image" alt="" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/95-1-35x35.jpg 35w, http://wwwcdn.goldminemag.com/wp-content/uploads/95-1-150x150.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/95-1-300x300.jpg 300w, http://wwwcdn.goldminemag.com/wp-content/uploads/95-1-768x765.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/95-1-1024x1020.jpg 1024w, http://wwwcdn.goldminemag.com/wp-content/uploads/95-1-80x80.jpg 80w, http://wwwcdn.goldminemag.com/wp-content/uploads/95-1.jpg 1506w" sizes="(max-width: 35px) 100vw, 35px" /><a href="http://www.goldminemag.com/blogs/goldmines-hall-of-fame-inductees-volume-95" title="Permalink to Goldmine&#8217;s Hall of Fame Inductees &#8211; Volume 95" rel="bookmark">Goldmine&#8217;s Hall of Fame Inductees &#8211; Volume 95</a></p>
			        		
			</div>

			<div class="tab-content" id="tabs2">
			<ul>

<ul>
<li>DavetheKnave: <a href="http://www.goldminemag.com/articles/sound-advice-misprints-errors-dont-always-mean-big-bucks#comment-554286" title="on Sound Advice: Misprints, errors don't always mean big bucks">Have a copy of the Woodstock T</a>...</li>
<li>Margarite: <a href="http://www.goldminemag.com/articles/record-prices-and-values-are-not-the-same-thing#comment-554281" title="on Go beyond book values when buying, selling and valuing records">I have a copy of Timmy Carr an</a>...</li>
<li>abrum8: <a href="http://www.goldminemag.com/giveaway/kiss-poster-giveaway-autographed-gene-simmons#comment-554269" title="on KISS poster Giveaway, autographed by Gene Simmons">abrum8@yahoo.com</a>...</li>
<li>tylerscott007: <a href="http://www.goldminemag.com/collector-resources/goldmine-record-show-calendar-may-2017-update#comment-554258" title="on Goldmine Record Show Calendar, May 2017 update">Please add me to your upcoming</a>...</li>
<li>CrankyYankee: <a href="http://www.goldminemag.com/articles/call-judas-priest-rock-hall#comment-554251" title="on A call for Judas Priest to be in the Rock and Roll Hall of Fame">Well....I dunno about J.P. but</a>...</li>
</ul>			</ul>
			</div>
			</div>
			<script type="text/javascript">OX_526fcbdfe7090.showAdUnit('468628');</script><br /><br /><script type="text/javascript">OX_526fcbdfe7090.showAdUnit('496016');</script><aside id="text-27" class="widget widget_text"><h3 class="widget-title">Products for Collectors</h3>			<div class="textwidget"><h3>Products for Collectors</h3>
<object width="300"><param name="movie" value="http://www.youtube.com/v/U_gmKSYdal8?fs=1&amp;hl=en_US"/><param name="allowFullScreen" value="true"/><param name="allowscriptaccess" value="always"/><embed src="http://www.youtube.com/v/U_gmKSYdal8?fs=1&amp;hl=en_US" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="300" height="250"/></object>
<div class="button" style="font-size:13px; padding:3px 7px; margin-left:65px; float:left;"><a href="http://www.spincleanrecordwasher.com/">Purchase Spin Clean</a></div></div>
		</aside><aside id="text-31" class="widget widget_text">			<div class="textwidget"><a href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B08" target="_blank"><img src="http://wwwcdn.goldminemag.com/wp-content/uploads/60-sub-offer.jpg"/></a></div>
		</aside> 

		</div><!-- #secondary .widget-area -->
		<div id="Offer"> <aside id="text-23" class="widget widget_text">			<div class="textwidget"><div class="left">SIGN UP for our free eNewsletter to get the latest in music collecting news and articles delivered to your inbox weekly and we'll give you.<br /><span style="color:#000;"><strong>A FREE PDF: Beatles Price Guide</strong></span></div>
<div class="right">
<!-- form here -->
</div></div>
		</aside>            <div id="et_form-div-quicksubscribe-292650" class="et-quick-subscribe et-form">
                <form id="form-quicksubscribe-292650"
                      name="form-quicksubscribe-292650" class="et_form"
                      action="/wp-content/plugins/fw-exacttarget-client/subscribe-form.php" method="POST"
                      onsubmit="return ET_LongFormSubmit('quicksubscribe-292650');">
                    <fieldset class="et_fieldset">
                        <input id="ETSubscriberKeyThxquicksubscribe-292650" name="ETSubscriberKey" type="hidden" /><input name="SubAction" type="hidden" value="sub_add_update" /><input name="formId" type="hidden" value="quicksubscribe-292650" /><ul style="list-style-type:none; margin:0; padding:0;" class="et_field_list"><li><label for="EmailAddressThx"><span class='required'>*</span>  </label><input type="text" autocomplete="off" id="EmailAddressThxquicksubscribe-292650" class="et_text" name="et_emailAddress" value="enter your email here" placeholder="enter your email here" onfocus="etEmailFocus('enter your email here',this)" onblur="if (this.value == '') {this.value = 'enter your email here';}" /></li><input type="hidden" name="et2_customField[1085723][Email Source Quick Subscribe]" value="True" class="" /><input type="hidden" name="et2_list[1085723][]" value="www.krausebooks.com" /><input type="hidden" name="et2_list[1085723][]" value="Goldmine Magazine" /><input type="hidden" name="et2_list[1085723][]" value="Goldmine Magazine eNewsletter" /><input type="hidden" name="et2_list[1085723][]" value="Goldmine Magazine Partners" /></ul><input type="hidden" id="thx309962" name="thx" value="http://www.goldminemag.com/thanks"  /><input type="hidden" id="err309962" name="err" value="http://wwww.goldminemag.com/subscribe-2/enewsletter/newsletter-error"  /><input type="hidden" name="et_emailSource" value="Main Content Site" /><input class='submit' name='submitSubscription' id='submit-quicksubscribe-292650' type='submit' value='GET MY FREE DOWNLOAD' /><div class="g-recaptcha" data-sitekey="6LdFPSgTAAAAAMofY_3o57b2wEzhNeixXonVaOlx"></div>                    </fieldset>
                    <input type="hidden" name="action" id="quicksubscribe-292650"
                           value="submitSubscription"/>
                    <input type="hidden" name="et_mid[]" value="1085723" />                </form>
            </div>
        </div>  
	
		<div id="primary">

				

					
		<h1 class="entry-title entry-header">Live, Rundgren is still a wizard, a true star</h1>

				<div class="entry-meta">
		Posted in <a href="http://www.goldminemag.com/reviews/concert-reviews/" rel="category tag">Concert Reviews</a>, <a href="http://www.goldminemag.com/reviews/" rel="category tag">Reviews</a> | Tags: <a href="http://www.goldminemag.com/tag/todd-rundgren/" rel="tag">Todd Rundgren</a>		
			<br /><time class="entry-date" datetime="2017-06-05T16:04:04+00:00" pubdate>June 5, 2017</time> | <span class="by-author"> <span class="author vcard"><a class="url fn n" href="http://www.goldminemag.com/author/goldmine1/" title="View all posts by Goldmine1" rel="author">Goldmine1</a></span></span>		</div><!-- .entry-meta -->
		
		<div class="social">
		<span class='st_twitter' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class="pinterest"><a href="http://pinterest.com/pin/create/button/?url=http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star&media=http://www.goldminemag.com/wp-content/uploads/todd-Rundgren.jpg&description=Live, Rundgren is still a wizard, a true star on http://www.goldminemag.com" class="pin-it-button" count-layout="none" style="width:28px; margin-bottom:-3px;">Pin It</a></span>
		<span class='st_email' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_stumbleupon' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_plusone' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_sharethis' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_ facebook' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_fblike' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		</div>

	<div class="entry-content">
		<p><strong>Todd Rundgren<br />
</strong><strong>Live at the U.S. Cellular Theater at the Bijou Theater<br />
</strong><strong>Knoxville Tennessee<br />
</strong><strong>May 31, 2017</strong></p>
<div id="attachment_309963" style="width: 885px" class="wp-caption aligncenter"><img class="size-full wp-image-309963" src="http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren.jpg" alt="" width="875" height="1280" srcset="http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren.jpg 875w, http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren-150x219.jpg 150w, http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren-205x300.jpg 205w, http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren-768x1123.jpg 768w, http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren-700x1024.jpg 700w, http://wwwcdn.goldminemag.com/wp-content/uploads/todd-Rundgren-103x150.jpg 103w" sizes="(max-width: 875px) 100vw, 875px" /><p class="wp-caption-text">Todd Rundgren, crooning his heart out. Photo ny Alisa B. Cherry on May 31, 2017 @ The Bijou Theatre in Knoxville, TN.</p></div>
<p>By Lee Zimmerman</p>
<p>A wizard, a true star, Todd Rundgren’s always managed to stay ahead of the curve when it comes to innovation, imagination and ground breaking technology. Lately, however, it seems he feels as if he’s been left behind, not taking advantage of the modern sounds and styles that seem so in vogue. Consequently his new album, White Knight, and the flashy new stage show that spotlights those songs find him intent on proving he’s still the wiz he was and well equipped to compete with any of todays’s perkier posers.</p>
<p>With much of the so-called “Hot Toddies” tour set list culled from that new album, the concert deemphasized the obvious hits The obligatory “Hello It’s Me” and the stunning “Just One World” showed up at the show’s conclusion, but other than a pair of old Utopia standbys “One World” and “Secret Society” and the iconic “No World Order,” few of his standards were featured. No “Bang on the Drum,” no “Black Maria,” no “It Wouldn’t Have Made Any Difference,” no “Can We Still Be Friends,” no old Nazz tune pulled out of the proverbial hat.</p>
<p>Still, to paraphrase one of those title, it didn’t make any difference. A dazzling display of lights, optics and special effects projected on a scrim situated behind Todd and his two kabuki dancers made the show a spectacle in and of itself. The audience was treated to a pretend newscast aimed at mocking Donald Trump and his many foibles (Rundgren had warned that Trump devotees wouldn’t feel welcome to his concert), a 3 D roller coaster ride, laser lights, and shifting color patterns, all accentuating Todd’s onstage antics. The band &#8212; drummer Prairie Prince, former keyboardist John Ferenzik, longtime bassist Kasim Sultan and guitarist Jesse Gress &#8212; was excellent, but almost seemed secondary as far as the show was concerned; obscured by the scrim that separated them from their leader, their main purpose was allowing Todd take the spotlight, play occasional guitar, and more often than not, simply sing.</p>
<p>And sing he did, mostly in a wail and croon that demonstrated his vocal prowess is even stronger and more assured than ever. He pranced, danced (often in an abbreviated shuffle that brought to mind the late James Brown), posed and acted out the role of show man, affecting some show biz schtick that emphazized the concert’s flashy theatrics. Much of the performance had a soulful edge, still with ample rock and even some occasional rap. One could count at least three costume changes, and despite a bit of a paunch, the soon to be 69 year old seemed every bit as zestful as he ever was. And every bit as playful as well. His attack on Trump during the song “Tin Foil Hat” was hysterical and hard-hitting. “God Said” was stunning, both as a sermon and as a searing tour-de-force. His dig at crass commercialism on “Buy My T” was superb, even to the point of tossing out tees to the audience. (Notably, only tees were available at the merch stand.) And if anyone had doubts about Rundgren’s rock reliability, “Buffalo Grass” proved he was still the committed rocker he always was. Even with all the effects and theatrics, the performance was, in fact, total Todd, similar in set up to Utopia with all the hints of pure prog pretence.</p>
<p>It’s heartening to find a vintage artist reinvent himself an stay cutting edge. But again, that’s something Rungren has reliably done throughout his fabled career. Long live the once and future Runt. May Rundgren continue to reign.</p>
<blockquote data-secret="iJMPRsvg6R" class="wp-embedded-content"><p><a href="http://www.goldminemag.com/features/ready-rundgren">Ready For Rundgren</a></p></blockquote>
<p><iframe class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="http://www.goldminemag.com/features/ready-rundgren/embed#?secret=iJMPRsvg6R" data-secret="iJMPRsvg6R" width="584" height="329" title="&#8220;Ready For Rundgren&#8221; &#8212; Goldmine Magazine" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
				<div class="social">
		<span class='st_twitter' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class="pinterest"><a href="http://pinterest.com/pin/create/button/?url=http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star&media=http://www.goldminemag.com/wp-content/uploads/todd-Rundgren.jpg&description=Live, Rundgren is still a wizard, a true star on http://www.goldminemag.com" class="pin-it-button" count-layout="none" style="width:28px; margin-bottom:-3px;">Pin It</a></span>
		<span class='st_email' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_stumbleupon' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_plusone' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_sharethis' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_ facebook' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		<span class='st_fblike' st_title='Live, Rundgren is still a wizard, a true star' st_url='http://www.goldminemag.com/reviews/live-rundgren-still-wizard-true-star' ></span>
		</div>
			</div><!-- .entry-content -->

		
</article><!-- #post-309962 -->

						<div id="comments">
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/reviews/live-rundgren-still-wizard-true-star#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://www.goldminemag.com/login/?redirect_to=http%3A%2F%2Fwww.goldminemag.com%2Freviews%2Flive-rundgren-still-wizard-true-star">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments -->

				

		</div><!-- #primary -->


	</div><!-- #main -->

	<footer id="colophon" role="contentinfo">

			
<div id="supplementary" class="two">
		<div id="first" class="widget-area" role="complementary">
		<aside id="text-24" class="widget widget_text">			<div class="textwidget"><div id="glinks" style="margin-left: 20px;">
 <h4>Advertisement</h4>

<script type="text/javascript"><!--
google_ad_client = "ca-pub-9670108431615045";
/* GMN300x250Box */
google_ad_slot = "4326084613";
google_ad_width = 300;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div>
		</aside><aside id="text-29" class="widget widget_text">			<div class="textwidget"><a href="http://cygnusradio.com/category/goldmine-radio-hour/"><img src="http://wwwcdn.goldminemag.com/wp-content/uploads/goldmine-radio-hour2.jpg"/></a></div>
		</aside><aside id="text-30" class="widget widget_text">			<div class="textwidget"><div id="splinks" style="margin-left: 20px;">
<h4>Sponsored Links</h4>

<a href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B04">Discover the Music Collector's Magazine</a>
<p>Receive 14 Issues for just $25.95</p>

<a href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B05">Save 60% off the Newsstand Price</a>
<p>When You Subscribe to Goldmine Today!</p>

<a href="https://ssl.palmcoastd.com/07639/apps/COMBO_MULTIAUTO_2?ikey=C**B06">Try a Digital Subscription of Goldmine</a>
<p>$19.99 Worldwide Rate</p>

<a href="https://ssl.palmcoastd.com/07639/apps/DIGITAL?ikey=I**C10">Take Goldmine on the Go</a>
<p>Now Available in Digital Format</p>

<a href="http://www.goldminemag.com/collector-resources/record-show-calendar/">Record Show Calendar</a>
<p>See a complete show schedule</p>

</div></div>
		</aside>	</div><!-- #first .widget-area -->
	
		<div id="second" class="widget-area" role="complementary">
		<aside id="text-21" class="widget widget_text">			<div class="textwidget"><img src="http://wwwcdn.goldminemag.com/wp-content/uploads/goldmine-footer-logo.png" /> <a href="/about-us">About Us</a> | <a href="/advertise">Advertising Information</a> | <a href="http://www.fwmedia.com/privacy" target="_blank">Privacy Policy</a> <span style="float:right;">&copy; <script>document.write(new Date().getFullYear());</script>  <a href="http://www.fwmedia.com" target="_blank">F+W</a> All rights reserved. </span></div>
		</aside>	</div><!-- #second .widget-area -->
	
	</div><!-- #supplementary -->

	</footer><!-- #colophon -->
</div><!-- #page -->
<script type="text/javascript" src="http://assets.pinterest.com/js/pinit.js"></script>

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5LJFPS"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/wpaudio-mp3-player/wpaudio.min.js?ver=3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.goldminemag.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.3'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=2.9.8'></script>
<script type='text/javascript' src='http://wwwcdn.goldminemag.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"7c6878bca9","applicationID":"42845558","transactionName":"YwFSYBBQXhdVUkRYWlpLcVcWWF8KG0JZX1JYAQ==","queueTime":0,"applicationTime":944,"atts":"T0ZRFlhKTRk=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>